Bug Hunting Session
Bug 63558 - Add language autodetection and language menu shortcuts
Summary: Add language autodetection and language menu shortcuts
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Language-Detection
  Show dependency treegraph
 
Reported: 2013-04-15 14:25 UTC by bugquestcontri
Modified: 2017-10-20 16:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Draw file with screen shot and explanations (123.89 KB, application/vnd.oasis.opendocument.graphics)
2013-04-15 14:25 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-04-15 14:25:05 UTC
Created attachment 77995 [details]
Draw file with screen shot and explanations

Problem description: 
Non of the installed languages is available for selection. Thus spellchecker cannot be used.

Installed languages:
- English (default)
- Japanese
- German
- Dutch

Non of the selected languages is offered for choice.

Languages offered are not installed:
- Hangul (Korean)
- Chinese


Steps to reproduce:
1 – Open Calc
2 – Type text in German
3 – Tools  / Languages => non of the installed languages is offered

Current behavior:
Non of the installed languages is available for selection. 

Expected behavior:
Selection of installed languages is available for selection to do spell checking.

Similar (or same) problem is observed in Draw but not yet reported in other applications.

In LibO 3.6.5.2 the same problem is observed


              
Operating System: Windows XP
Version: 4.0.2.2 release
Comment 1 Urmas 2013-04-16 01:43:43 UTC
An enhancement request.
Comment 2 bugquestcontri 2013-04-16 16:40:00 UTC
Thanks for looking already into this report. However, as there is no workaround (at least I haven't found one yet), may I suggest to flag this as bug and not as an enhancement? Spell checking is not possible with German or Dutch text.Only English works.
Comment 3 Urmas 2013-04-17 12:31:23 UTC
You can assign a language via Format/Cells menu. It won't probably work until the application is restarted, but that is fdo#60062.
Comment 4 bugquestcontri 2013-04-19 14:03:52 UTC
Thanks for the hint with Format / Cells however this window does not contain and tab for language settings.

Selecting a cell and Tools / Languages is also not possible because non of the installed languages show up; only Korean and Chinese

Additionally I just made test with Draw. It is not possible to use the spell checker for German and Dutch. Thus the same situation as in Calc.

I am sorry but for me this is not an enhancement but a rather serious bug.
Comment 5 bugquestcontri 2013-04-19 14:10:16 UTC
Curiosity made me checking also the situation with Impress. It is the same as for Calc and Draw.

In Writer, I reported this earlier, German works, I can select the language but Dutch is not recognized, instead Afrikaans is shown. Dutch is installed and Afrikaans not.
Comment 6 Urmas 2013-04-30 12:03:53 UTC
Language lists in those menus are built in a way not related to spelling.
Comment 7 bugquestcontri 2013-05-03 04:44:58 UTC
@Urmas - I understand your comment 6 the way that the menu of languages which appears when opening Tools / Languages is independet of 
- the languages installed
- the language used?

Addtionally I do not agree with the fact that "spell checking is not possible with German or Dutch text" is an enhancement request but a bug. 

Such considerations are pushing people away from a great tool called LibO.At least I will have a first look at AOO when I need to spell check in German or Dutch.
Comment 8 bugquestcontri 2014-11-26 07:47:40 UTC
I still see the bug in Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
and asked a question with detailed description in AskLibO: http://ask.libreoffice.org/en/question/42885/dictionairies-dont-work-in-calc/

I would really be happy if this problem could be solved and I expect that very many other users would like this fix very much.