Download it now!
Bug 63676 - SVG not imported correctly into Draw
Summary: SVG not imported correctly into Draw
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2013-04-18 09:25 UTC by Clemens Eisserer
Modified: 2018-06-20 17:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
svg file which isn't imported correctly (56.73 KB, image/svg+xml)
2013-04-18 09:25 UTC, Clemens Eisserer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-04-18 09:25:00 UTC
Created attachment 78173 [details]
svg file which isn't imported correctly

The attached SVG is not imported correctly into Draw, when opening it with "File->Open".
Comment 1 Thomas van der Meulen 2013-04-18 15:53:28 UTC
Hello Clemens I can confirm that it doesn't open's as it should. 
It opens good with Safari webbrowser.

version: 4.0.3.1
os:Mac osx 10.8.3
Comment 2 Gerry 2013-04-30 15:00:35 UTC
Yes, import (File->Open) is unusable with LibreOffice 4.0.0.3 and 3.6.2.2 on Ubuntu 12.10. It imports the poster template just as a black box.

Inserting the file (Insert->Picture->Open File) works fine in 3.6.2.2, but then the vector data are lost, of courses. In LibreOffice 4.0.0.3 inserting does work, but the text is wrongly imported. This is a regression.
Comment 3 Gerry 2013-11-28 14:14:11 UTC
Tested SVG in LibreOffice 4.2 Beta1:

* Insert as image in Writer: Import perfect, except for the text. The text formatting is wrong. This is still the regression described in comment 2 from LO 3.6.x to 4.0.x. 
* Open SVG file in Draw: Terrible result. The entire page is one big black box. Unusable.
Comment 4 A (Andy) 2015-04-05 20:43:28 UTC
Reproducible with LO 4.4.1.2, Win 8.1

The attached svg sample file is not shown correctly.  All the text is missing as also the two small images in the top left.
Comment 5 Xisco Faulí 2015-12-02 17:12:04 UTC

*** This bug has been marked as a duplicate of bug 32248 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 05:49:44 UTC
Migrating Whiteboard tags to Keywords: (filter:svgOpen, filter:svgInsert)
[NinjaEdit]