Download it now!
Bug 63696 - EDITING: serious performance problems in ods file, such as typing text, apply style, ...
Summary: EDITING: serious performance problems in ods file, such as typing text, apply...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf
Depends on:
Blocks:
 
Reported: 2013-04-18 21:33 UTC by marcos
Modified: 2016-08-31 10:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
the spreadsheet with performance problem (1.52 MB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-18 21:33 UTC, marcos
Details
backtrace log (39.59 KB, text/x-log)
2013-04-18 22:03 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcos 2013-04-18 21:33:22 UTC
Created attachment 78198 [details]
the spreadsheet with performance problem

Problem description: 

I have a sheet with a lot of calculations. It works well in 3.x versions.
I have changed to 4.0.2 and it is impossible to work. Any operation take too much time and use all CPU available.
And as operation is anything in editing, since format a cell or fill a cell with text (no calculations envolved)

Steps to reproduce:
1. .... edit any text cell
2. ....
3. ....

Current behavior:

too solow

Expected behavior:

work
Operating System: Windows XP
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-04-18 21:50:59 UTC
Hi,

Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.2. The document opens OK (+/-20 seconds or so). Type text in a cell goes as fast as it should be, but when you hit enter afterwards (to 'apply' it) it'll freeze for about 5 second or so.

I try to open the same spreadsheet using LibreOffice Version: 4.1.0.0.alpha0+
Build ID: 74af27fef6505d4e47b53ea765b9cc4a96629fa , but I'm keep receiving errors mentioned below. After a moment LibreOffice just freezes completely (document doesn't open).

warn:legacy.osl:3589:1:xmloff/source/core/xmlerror.cxx:184: An error or a warning has occurred during XML import/export!
Error-Id: 0x20040003
    Flags: 2 ERRROR
    Class: 4 API
    Number: 3
Parameters:
    0: CharEscapementHeight
Exception-Message: UNKNOWN_PROPERTY
Position:
    Public Identifier: 
    System Identifier: file:///home/joren/Downloads/cp_13_V1_Last_version.ods
    Row, Column: 2,38096007

Therefore I mark this as NEW

Priority
Major: can't open it anymore using master, editing goes slow + our own file format (ods)
High: default priority for major bugs.

kind regards,
Joren
Comment 2 Jorendc 2013-04-18 21:53:56 UTC
@Kohei, Eike, Markus: Seems like a very nasty issue with an ods file. 4.0.2.2 opens it, but is quite slow when trying to edit it. Using master 4.1.0.0 version we can't even open it anymore. Because it is our own file format, I think you core devs should be warned? (if not, shoot me ;-) ).

Kind regards,
Joren
Comment 3 Jorendc 2013-04-18 22:03:42 UTC
Created attachment 78200 [details]
backtrace log
Comment 4 marcos 2013-04-19 14:28:26 UTC
today I tested using openoffice 3.2.1  it works fine.   The problem is not with the spreadsheet.
In fact it has a lot of calculation, table lookup and indirect references in formulas (a sofisticate use). But not healy odd.
I guess I also had no trouble using with libreoffice 3.x versions.  The problem appear serious in 4.x version.
As it are is impossible to use the sheet because any action in this sheet is too slow, not only edit but just use it.
Comment 5 Cor Nouws 2014-06-22 16:13:19 UTC
Marcos, how does this work for you in 4.3.0.1 or 4.2.5.2 pls?
thanks,
Cor
Comment 6 marcos 2014-06-27 16:11:40 UTC
hi,

worst.

I am still using openoffice 3.2 o use the spreadsheet.

I have a windows 7 with Libre 4.2

it crash when try to work in this sheet.

I have colleges who use Libre in MAC OS and they can work in this sheet. It is not so fast as I do with openoffice, but, works.

in may case I don't know it is regards the windows version or if it is regards I have only 4GB of memory.

But, in my case the libre just crash.
Comment 7 Buovjaga 2014-11-25 08:56:15 UTC
On Windows I experienced the slowness when making changes.
On Ubuntu I get the same debug messages as comment 1, but the document opened after a few minutes.

These are the messages after the document opened:
warn:sfx.control:3303:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:legacy.osl:3303:1:vcl/source/gdi/image.cxx:395: ImageAryData::Load: failed to load image 'cmd/lc_conditionalformatdialog.png'
warn:legacy.osl:3303:1:sfx2/source/sidebar/ResourceManager.cxx:444: context name not recognized
warn:sfx.control:3303:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:legacy.tools:3303:1:vcl/inc/svdata.hxx:390: object deleted while in use !
warn:vcl.control:3303:1:vcl/source/control/button.cxx:2248: No new-style group set on radiobutton <> using old-style digging around
warn:vcl.layout:3303:1:vcl/source/window/builder.cxx:1424: making metric box for type: GtkComboBox unit: degrees name: orientationdegrees use a VclComboBoxNumeric instead
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4724: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment
warn:vcl.layout:3303:1:vcl/source/window/toolbox.cxx:4090: only tabitems with window supported at the moment

These are the messages after editing (refresh took maybe a minute compared to the 5 sec on Windows):
warn:vcl.control:3303:1:vcl/source/control/button.cxx:2248: No new-style group set on radiobutton <> using old-style digging around
warn:sfx.control:3303:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:vcl.control:3303:1:vcl/source/control/button.cxx:2248: No new-style group set on radiobutton <> using old-style digging around
warn:sfx.control:3303:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 772befa08f02b08da1ab493896a0744bc73781c7
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-23_22:39:02

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 772befa08f02b08da1ab493896a0744bc73781c7
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-23_23:25:11
Comment 8 Buovjaga 2015-01-10 05:46:33 UTC
It's true that in 3.3 the slowness is not present, but it appears already in 3.5, so even though this might be a regression, it cannot be bibisected.

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 9 marcos 2015-01-12 12:39:20 UTC
I am working well with open Office 3.4.1

For your information is impossible to open this files with libreOffice, it crashs always.
Comment 10 Cor Nouws 2015-01-12 12:52:38 UTC
opens is 4.4.0.2 on Linux 32 bits.
Not fast.
Changing a cell value is slowwwww

The file is from 19-09-2000, so there might be some old stuff that handled slow now?
Comment 11 marcos 2015-01-12 12:54:32 UTC
I can give you a new file, if you want.
Comment 12 Robinson Tryon (qubit) 2015-12-10 02:02:47 UTC Comment hidden (obsolete)
Comment 13 Cor Nouws 2016-08-30 20:06:09 UTC
(In reply to marcos from comment #11)
> I can give you a new file, if you want.

I just tried in Version: 5.3.0.0.alpha0+
Build ID: 139d3b3e8b157c1f365f888126269f0902acbaa2
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-26_00:01:39
Locale: nl-NL (nl_NL.UTF-8); Calc: group

and it works fine, I think.
Can you check it in a recent version, 5.2.1.2 for example or a recent daily
  http://www.libreoffice.org/download/pre-releases/
  http://dev-builds.libreoffice.org/daily/master/
thanks!
Comment 14 marcos 2016-08-31 09:44:02 UTC
I tested with 5.0.6.3

The problem doesn't appear.  It works
Comment 15 Buovjaga 2016-08-31 10:08:58 UTC
Great to hear -> WFM.