Download it now!
Bug 63710 - Changing alignment does not work for some Textboxes
Summary: Changing alignment does not work for some Textboxes
Status: RESOLVED DUPLICATE of bug 58492
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-19 08:05 UTC by Clemens Eisserer
Modified: 2017-06-05 00:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test document which exhibits the issue (71.45 KB, application/vnd.oasis.opendocument.graphics)
2013-04-19 08:05 UTC, Clemens Eisserer
Details
the pdf file which was used as template for the drawing (416.77 KB, application/pdf)
2013-04-19 08:07 UTC, Clemens Eisserer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-04-19 08:05:02 UTC
Created attachment 78217 [details]
test document which exhibits the issue

For some Textboxes, modifying the alignment (left, center, right) does not work.

Please see the screencast at  http://youtu.be/Ez9CLQSIZuQ and the attached test-case drawing.
Comment 1 Clemens Eisserer 2013-04-19 08:06:26 UTC
Forgot to mention, this drawing was created by importing a pdf-file (also attached)
Comment 2 Clemens Eisserer 2013-04-19 08:07:25 UTC
Created attachment 78218 [details]
the pdf file which was used as template for the drawing
Comment 3 A (Andy) 2013-04-19 22:01:32 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

For the title field it is not possible to amend the alignment of the text.

@Fridrich: Do you maybe have an explanation for this?
Comment 4 Owen Genat (retired) 2013-10-14 23:08:21 UTC
This bug may be a duplicate of bug #58492 which illustrates how a text box created by initially clicking and then entering text (i.e., default method) does not subsequently allow aligning of content by clicking the toolbar alignment buttons. If on the other hand the text box is initially created via click-n-drag (i.e., custom method) then the alignment buttons on the toolbar work as expected.

The screencast in the description indicates the custom method, when creating a new text box, but it is not clear how the upper text box (which suffers an alignment problem) was created. Was it created by the default method and subsequently re-sized? If yes, then this bug is a duplicate. If no, then we may need to further clarify the exact nature of the textbox causing the problem.
Comment 5 QA Administrators 2015-04-19 03:21:01 UTC Comment hidden (obsolete)
Comment 6 Clemens Eisserer 2015-04-19 18:19:51 UTC
Of course still present in LibreOffice-4.4.0.3
Comment 7 QA Administrators 2017-05-22 13:23:38 UTC Comment hidden (obsolete)
Comment 8 Clemens Eisserer 2017-05-22 20:33:02 UTC
Still reproduceable with: 5.3.3.2 on Linux
Comment 9 Maxim Monastirsky 2017-05-22 22:58:22 UTC
Select the textbox, right click > Text..., select the "Full width" checkbox, click OK => problem is gone. But the UX is indeed not ideal.
Comment 10 Thomas Lendo 2017-06-05 00:25:40 UTC
Set this bug as duplicate of bug 58492.
Closing as RESOLVED DUPLICATE.

*** This bug has been marked as a duplicate of bug 58492 ***