Bug Hunting Session
Bug 63758 - Formula displays incorrectly in Writer frames
Summary: Formula displays incorrectly in Writer frames
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-20 19:22 UTC by Mike Smith
Modified: 2015-02-19 12:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
One page Writer file (25.75 KB, application/vnd.oasis.opendocument.text)
2013-04-20 19:22 UTC, Mike Smith
Details
Screenshot: I think I can't reproduce (101.23 KB, image/png)
2013-06-20 23:33 UTC, Jorendc
Details
Formula-Frame Bug (61.47 KB, image/png)
2013-06-22 20:26 UTC, Mike Smith
Details
ODTs containing formula in/out of frame under various versions of LO. (69.59 KB, application/zip)
2013-12-09 10:09 UTC, Owen Genat (retired)
Details
Screen Shot Formula-Frame Bug (204.22 KB, image/png)
2014-07-08 19:15 UTC, Mike Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Smith 2013-04-20 19:22:44 UTC
Created attachment 78280 [details]
One page Writer file

Math division command (as a fraction) does not display in Writer frames. So markup text: a over b displays correctly on Writer page, but when inserted in a frame, the horizontal division line generated by "over" command does not appear.
Comment 1 Jorendc 2013-06-20 23:33:05 UTC
@Mike: you mind retesting this using LibreOffice 4.0.4 (http://www.libreoffice.org/download) or LibreOffice 4.1.0 RC1 (http://www.libreoffice.org/download/pre-releases/)?

I can not reproduce this issue using Mac OSX 10.8.3 with LibreOffice 4.1.0.1 rc1.

Kind regards,
Joren

PS: will upload a screenshot
Comment 2 Jorendc 2013-06-20 23:33:45 UTC
Created attachment 81139 [details]
Screenshot: I think I can't reproduce
Comment 3 ign_christian 2013-06-21 06:18:31 UTC
Not reproducible on LO 4.0.4.2 (Win7 32bit), same result as Jorendc.
Perhaps it's been fixed.
Comment 4 ign_christian 2013-06-22 00:52:39 UTC
I also can't reproduce on LO 3.6.6.2 (Ubuntu 12.04 32bit)

So should be WORKSFORME per comment 1, comment 3, comment 4. I think Jorendc would agree :)
Comment 5 Mike Smith 2013-06-22 04:08:18 UTC
I continue to have the same problem in Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2). Not resolved for me.
Comment 6 ign_christian 2013-06-22 07:07:33 UTC
Strange..please attach screenshot of that wrong behavior & inform your OS too.

Have you tried resetting user profile?
Comment 7 Mike Smith 2013-06-22 20:26:08 UTC
Created attachment 81228 [details]
Formula-Frame Bug

I reset user profile, but problem persists. I do not have this problem on my IBM Thinkpad T61 running Windows 7 Home Premium 32-bit(with various versions of LibreOffice). The problem occurs only on my desktop computer running Windows 7 Home Premium 64-bit. Has anyone else tried to replicate on the 64-bit version of Windows 7 Home Premium?
Comment 8 retired 2013-11-23 19:00:35 UTC
Sorry for missing the obvious but what is not displaying correctly? Could you please provide a screenshot?

Example file looking good to my eyes on OS X 10.9, LO 4.1.3.2 and Version: 4.3.0.0.alpha0+
Build ID: 73342dbb82ba074d01962359dac50fb2aa36cbeb
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-22_07:09:14

Windows only I guess.

Is this any better with 4.1.3.2 for you?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 9 Owen Genat (retired) 2013-12-09 10:09:52 UTC
Created attachment 90501 [details]
ODTs containing formula in/out of frame under various versions of LO.

(In reply to comment #8)
> Sorry for missing the obvious but what is not displaying correctly? Could
> you please provide a screenshot?

There is a screenshot provided in attachment 81228 [details]. I can't reproduce the bug though. I have created ODTs (refer attached) including an object with the indicated formula under Ubuntu 10.04 x86_64 using:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

... as well as under Windows 7 (6.1.7601) using:

- v4.1.2.2 Build ID: 281b75f427729060b6446ddb3777b32f957a8fb

None of the files exhibit the missing vinculum / virga when the formula is contained in a frame.
Comment 10 QA Administrators 2014-07-08 17:29:12 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 11 Mike Smith 2014-07-08 19:15:20 UTC
Created attachment 102448 [details]
Screen Shot Formula-Frame Bug

Screen shot displaying lack of horizontal bar in division (fraction) formula inserted within Writer frame.
Comment 12 ign_christian 2014-07-09 03:07:42 UTC
Mike, please retest using LO 4.2.5.2 and/or 4.3.0.2 then mark this bug UNCONFIRMED
Comment 13 Mike Smith 2014-07-09 13:54:51 UTC
The screenshot I uploaded yesterday was from Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5. Problem persists (for me) with the current version of LibreOffice.
Comment 14 Buovjaga 2014-11-02 14:56:16 UTC
Formulas work fine here.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b167d1127e1579468a74c4414e7f4f33d9d24122
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-02_03:04:44
Comment 15 raal 2014-12-30 12:02:24 UTC
I can not confirm with LO 4.3.5, win7
Comment 16 tommy27 2015-01-18 11:20:05 UTC
(In reply to raal from comment #15)
> I can not confirm with LO 4.3.5, win7

me neither with LibO 4.3.5.2 under Win8.1 x64
I set status to RESOLVE WORKSFORME

@Mike Smith
please verify with latest LibO release if it's fixed for you as well
Comment 17 Buovjaga 2015-02-19 12:57:47 UTC
Set status to RESOLVED WORKSFORME.