Download it now!
Bug 63782 - cmx import faulty (no colors), while cdr import is correct
Summary: cmx import faulty (no colors), while cdr import is correct
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libcdr (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-21 17:25 UTC by ralf.krapf
Modified: 2018-03-08 15:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original CMX-File (34.93 KB, image/x-cmx)
2013-04-21 17:25 UTC, ralf.krapf
Details
Converted to CDR via Corel (1.37 MB, application/vnd.corel-draw)
2013-04-21 17:26 UTC, ralf.krapf
Details
Imported from CMX-File (20.18 KB, application/vnd.oasis.opendocument.graphics)
2013-04-21 17:26 UTC, ralf.krapf
Details
Imported from CDR-file (17.48 KB, application/vnd.oasis.opendocument.graphics)
2013-04-21 17:27 UTC, ralf.krapf
Details
Screenshot: Correct CDR-import (365.86 KB, image/png)
2013-04-21 17:27 UTC, ralf.krapf
Details
Screenshot: Incorrect CMX-Import (424.90 KB, image/png)
2013-04-21 17:28 UTC, ralf.krapf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ralf.krapf 2013-04-21 17:25:06 UTC
Hi

Steps to reproduce:
1)
- Import the "5corp.cmx" in Libreoffice
2)
- The Import is not correct, the colors are missing. It looks like the "outline mode" in corel draw.
3)
- Save the "5corp.cmx" in Corel Draw as "5corp.cdr"
4)
- Import the "5corp.cdr" once again in Libreoffice
5)
- The import is perfect

So, there are no special effects in the CDR-Drawing, but it seems the handling of different file-extensions is the problem.

Note: A lot of Corel cliparts on the web are in this .cmx-format (Corel presentation exchange).

System:
-Windows 7
-CorelDraw X5 15.2.0.686
-LibreOffice 4.0.3.1

Thanks
Ralf
Comment 1 ralf.krapf 2013-04-21 17:25:38 UTC
Created attachment 78301 [details]
Original CMX-File
Comment 2 ralf.krapf 2013-04-21 17:26:19 UTC
Created attachment 78302 [details]
Converted to CDR via Corel
Comment 3 ralf.krapf 2013-04-21 17:26:43 UTC
Created attachment 78303 [details]
Imported from CMX-File
Comment 4 ralf.krapf 2013-04-21 17:27:08 UTC
Created attachment 78304 [details]
Imported from CDR-file
Comment 5 ralf.krapf 2013-04-21 17:27:36 UTC
Created attachment 78305 [details]
Screenshot: Correct CDR-import
Comment 6 ralf.krapf 2013-04-21 17:28:08 UTC
Created attachment 78306 [details]
Screenshot: Incorrect CMX-Import
Comment 7 Thomas van der Meulen 2013-04-21 17:47:39 UTC
Hello Ralf, 
I can confirm that it doesn't load the collor in the .cmx file, and it loads the collor with the .CDR file. 

version: Master 4.1.0.0.alpha0+
Build ID: cf3e8cf92190baddf601283855070a36fc89125
& LibreOffice 4.0.3.1 
os: mac osx 10.8.3
Comment 8 QA Administrators 2015-04-19 03:22:27 UTC Comment hidden (obsolete)
Comment 9 ralf.krapf 2015-04-29 19:35:32 UTC
Still the same behavior with
Win8.1 64 bit / LO 4.4.2.2
Comment 10 David Tardon 2018-03-08 15:45:46 UTC
Fixed in libcdr 0.1.3.