Bug 63800 - EDITING: Input lists in write protected sections not updated in window when edited
Summary: EDITING: Input lists in write protected sections not updated in window when e...
Status: RESOLVED DUPLICATE of bug 79409
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
: 70307 79265 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-22 11:41 UTC by Basta
Modified: 2015-12-17 07:13 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Basta 2013-04-22 11:41:54 UTC
Problem description: 

Steps to reproduce:
1. Create new section in a text document
2. Add a input field in that section
3. Write protect the section
4. Write some text in the input field and close it

Current behavior:
When the input field is changed or edited, the field is not updated in the window. All changes are there if you open the input field for editing again, but it does not show in the window after closing the input field. After forcing window update with F9 it looks fine.
Expected behavior:
After editing and closing a input field the new content of the input field should be present in the window.

              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 IT 2013-08-26 06:30:24 UTC
I can confirm this bug still exists with version 4.0.4 4.0.5 and 4.1.1 RC2

Windows 7 x64
Comment 2 Rudolf Kollien 2013-11-15 12:44:32 UTC
This bug still exists in 4.1.3.2 (Linux).
Last version seen working correct was 3.6.x
It doesn't matter, if the section is protected with a password too or not.

This bug is very annoying in forms where it is essential, that the user can only fill in fields but is not allowed to change the text.

Hitting key F9 or refresh via menu works. Then the new content of the input field is shown.

Check fields in protected sections work like expected: checking/unchecking is shown immediately. Seems the bug is only related to input fields.
Comment 3 Joel Madero 2014-07-09 06:38:59 UTC
*** Bug 70307 has been marked as a duplicate of this bug. ***
Comment 4 ign_christian 2014-07-09 07:46:14 UTC
It's correct in 3.5.7.2, 3.6.7.2 - Ubuntu 12.04 x86

Problem still reproduced until 4.2.5.2 and 4.3.0.2

@Rudolf, I change version back since that indicates oldest version when problem seen.
Comment 5 Matthew Francis 2014-12-04 04:21:10 UTC
In 4.3.4.1 and current 4.5 master, input fields in protected sections are already able to be edited

However, input lists (see the file in bug 70307, which was earlier closed in favour of this bug) still aren't. Editing the subject to suit.


Results of bibisecting in 43all (for input lists):

79e02001f27d33b3b478324ab6fba5683413b4d9 is the first bad commit
commit 79e02001f27d33b3b478324ab6fba5683413b4d9
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 04:56:54 2012 +0000

    source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
    
    commit b6c016da23d309b4ac7d154bc33a22397974ed73
    Author:     Tor Lillqvist <tml@iki.fi>
    AuthorDate: Mon Nov 19 11:16:15 2012 +0200
    Commit:     Tor Lillqvist <tlillqvist@suse.com>
    CommitDate: Mon Nov 19 12:26:44 2012 +0200
    
        Use gb_VISIBILITY_FLAGS
    
        Change-Id: I6be70c0b8d73f4d1d1428c0df94ea6d8bdc782f7


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect bad 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [51b63dca7427db64929ae1885d7cf1cc7eb0ba28] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good 51b63dca7427db64929ae1885d7cf1cc7eb0ba28
# bad: [d65a58c31c8da044ef66ae4517fa2fe74cec0019] source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
git bisect bad d65a58c31c8da044ef66ae4517fa2fe74cec0019
# bad: [79e02001f27d33b3b478324ab6fba5683413b4d9] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect bad 79e02001f27d33b3b478324ab6fba5683413b4d9
# good: [183a576d94de9a9439d580c8b81f335ab57cdbdc] source-hash-a599f5b4b51848e3b397d471c9d12b373caadcef
git bisect good 183a576d94de9a9439d580c8b81f335ab57cdbdc
# good: [a67b874d60de1f1a44bef57a53a7b8a84db0ba58] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect good a67b874d60de1f1a44bef57a53a7b8a84db0ba58
# good: [221bf5c0db153e24c67ff29fe614af7cc010a356] source-hash-9210b95bcfd65ae558f445666d9b880e794d4c74
git bisect good 221bf5c0db153e24c67ff29fe614af7cc010a356
# first bad commit: [79e02001f27d33b3b478324ab6fba5683413b4d9] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
Comment 6 Matthew Francis 2015-01-15 11:01:54 UTC
Input lists seem to have stopped updating properly at the below commit.

Adding Cc: to cedric.bosdonnat.ooo@free.fr; Could you possibly take a look at this? Thanks


commit dcb080347ca127044313bbb3c11c37761cc2a7a2
Author: Cédric Bosdonnat <cedric.bosdonnat@free.fr>
Date:   Fri Nov 16 13:37:04 2012 +0100

    n#780277: select field when clicking it instead of having cursor before it
    
    Change-Id: I93d623b62e9357a71bfca3403cc98092ef58c7e4
Comment 7 Kulo 2015-01-20 13:57:24 UTC
*** Bug 79265 has been marked as a duplicate of this bug. ***
Comment 8 Kulo 2015-06-08 12:18:25 UTC

*** This bug has been marked as a duplicate of bug 79409 ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 07:13:56 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]