Bug 63823 - Extension GetQuote 1.1: Installation fails with Java error message
Summary: Extension GetQuote 1.1: Installation fails with Java error message
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL: http://extensions.openoffice.org/de/p...
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-04-23 04:55 UTC by Rainer Bielefeld Retired
Modified: 2015-12-15 22:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-23 04:55:58 UTC

    
Comment 1 Rainer Bielefeld Retired 2013-04-23 05:07:20 UTC
Steps how to reproduce with  "LibreOffice 3.6.6.2 release " German UI/ German Locale [Build-ID: f969faf] {pull date 2013-04-03} on German WIN7 Home Premium (64bit) 

Steps how to reproduce:
0. Download Extension
1. Launch LibO
2. Make Java 1.7 available if necessary vie 'Tools -> Options'
3. Menu 'Tools -> Extensions Manager -> Add'
4. Browse for downloaded "GetQuote.oxt" and install  
   Bug: Error Message "java.lang.reflect.InvocationTargetException"

Worked fine with 3.5.7, so regression
No idea whether this is a LibO problem or a problem with the extension.
Comment 2 Rainer Bielefeld Retired 2013-04-23 06:33:02 UTC
I left a request for assistance on <http://extensions.openoffice.org/de/project/GetQuote#comment-6589>
Comment 3 Robinson Tryon (qubit) 2013-10-16 16:01:15 UTC
Changing 'regression' -> 'PossibleRegression' until we can get independent confirmation of a regression.
Comment 4 Robinson Tryon (qubit) 2013-10-16 16:23:55 UTC
Given URL is localized in German, here's the stock url:
http://extensions.openoffice.org/project/GetQuote

Steps:
0. Download Extension

Downloaded the latest version of GetQuote listed (1.1?)

1. Launch LibO

Testing on LO 4.1.2.3 on Ubuntu 12.04.3

2. Make Java 1.7 available if necessary vie 'Tools -> Options'

N/A

3. Menu 'Tools -> Extensions Manager -> Add'
4. Browse for downloaded "GetQuote.oxt" and install  

I don't get any error message, but the Extension Manager freezes and is non-responsive (I let it sit for 10+ minutes).

RESULT:
The latest version of GetQuote appears to be incompatible with a recent build of LibreOffice

TRIAGE:
This is not one of the extensions covered by our development process, so the Extension Author should be contacted for support.

Status: UNCONFIRMED -> RESOLVED NOTOURBUG
Comment 5 Stephan Bergmann 2013-10-17 10:09:28 UTC
(In reply to comment #4)
> Given URL is localized in German, here's the stock url:
> http://extensions.openoffice.org/project/GetQuote
> 
> Steps:
> 0. Download Extension
> 
> Downloaded the latest version of GetQuote listed (1.1?)

I only find a version 1.0 one there, with a "Download" button leading to <http://extensions.openoffice.org/en/download/4082>.  (And I cannot reproduce any of the problems with that getquote.oxt with any of my local libreoffice-3-6, libreoffice-4-1 and master builds on Fedora 19 against OpenJDK 1.7.0_40, neither the java.lang.reflect.InvocationTargetException from comment 1 nor the freeze from comment 4.)

> TRIAGE:
> This is not one of the extensions covered by our development process, so the
> Extension Author should be contacted for support.
> 
> Status: UNCONFIRMED -> RESOLVED NOTOURBUG

(Note that even then, it might be an inadvertent incompatibility on the LO side.  Therefore, it is always desirable to understand exactly why problems occur with a given extension before closing as NOTOURBUG.)
Comment 6 Robinson Tryon (qubit) 2013-10-17 14:49:19 UTC
(In reply to comment #5)
> 
> (Note that even then, it might be an inadvertent incompatibility on the LO
> side.  Therefore, it is always desirable to understand exactly why problems
> occur with a given extension before closing as NOTOURBUG.)

Stephan: I agree with your reasoning. My understanding was that development resources were focused on our core product and any bundled extensions. I'd be happy to triage and accept bugs relating to external extensions if the devs are willing to follow-through with them.
Comment 7 Stephan Bergmann 2013-10-17 14:58:22 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > 
> > (Note that even then, it might be an inadvertent incompatibility on the LO
> > side.  Therefore, it is always desirable to understand exactly why problems
> > occur with a given extension before closing as NOTOURBUG.)
> 
> Stephan: I agree with your reasoning. My understanding was that development
> resources were focused on our core product and any bundled extensions. I'd
> be happy to triage and accept bugs relating to external extensions if the
> devs are willing to follow-through with them.

There is no easy answer here.  If the bug is caused by an inadvertent incompatibility in LO we would certainly like to know about it and fix it.  But finding out the root cause of an extension problem can of course be quite difficult.
Comment 8 Robinson Tryon (qubit) 2015-12-15 22:05:14 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]