Download it now!
Bug 63824 - Extension GetQuote 1.1: breaks cell formatting
Summary: Extension GetQuote 1.1: breaks cell formatting
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://extensions.openoffice.org/de/p...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-23 05:42 UTC by Rainer Bielefeld Retired
Modified: 2015-04-23 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document from Version 4.0.1.0+ (Build ID: 693217465486667d38c3b7cd6d654136fe1efc8) (7.82 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-04-23 05:42 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-23 05:42:23 UTC
Created attachment 78356 [details]
Sample Document from Version 4.0.1.0+ (Build ID: 693217465486667d38c3b7cd6d654136fe1efc8)

Steps how to reproduce with parallel Dev. Installation of "LODev  4.0.1.0+   -  English UI / German Locale  [Build ID: 693217465486667d38c3b7cd6d654136fe1efc8)]"  {tinderbox: @6, pull time  2013-02-03 09:04:55} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\401\

1. Enable Java, download extension
2. Install extension, close and reopen LibO
3. Create sample document due to    "Bug 62472 - 
   Extension GetQuote 1.1: Cells referring to values with wrong value"
   with additional C1: "=B1", D1: "=A1-B1", E: "12345", F: "=12345"
   > Nothing unexpected
5. Save -> close -> reopen
6. clicking on row header 1 select all row 1
7. Menu 'Format -> Cells > No of decimals = 8' <ok>
   Expected: all cells with 8 decimals
   Actual: only cell without formula updated to new formatting
            <control+shift+f9> will heal the problem

The problem might depend on version with what your document has been created, so please do your tests with own documents after a first quick test with attached sample.ods
Comment 1 Rainer Bielefeld Retired 2013-04-23 05:43:12 UTC
More research when this started and concerning relation to Bug 62472 required
Comment 2 Rainer Bielefeld Retired 2013-04-23 05:58:27 UTC
Already reproducible with
* Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile
* server installation of "LibreOffice 3.5.7.2  German UI/Locale [Build-ID: 3215f89-f603614-ab984f2-7348103-1225a5b] on German WIN7 Home Premium (64bit)

Was still ok with
* unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile (????)
* server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)

Comparing results LOdev  4.0.0.0.alpha1+  and LibO  4.0.0.3 my suspect is that this one might be related to something completely different from Version?
Comment 3 Rainer Bielefeld Retired 2013-04-23 06:33:04 UTC
I left a request for assistance on <http://extensions.openoffice.org/de/project/GetQuote#comment-6589>
Comment 4 tommy27 2013-08-20 17:00:28 UTC
changing version to 4.0.3 according to Comment 2
Comment 5 QA Administrators 2015-04-01 14:41:34 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 6 Buovjaga 2015-04-23 14:53:35 UTC
This extension seems dead. An actively developed replacement: http://extensions.libreoffice.org/extension-center/smf-extension
Closing as NOTOURBUG.