Bug Hunting Session
Bug 64005 - FILEOPEN: Centered heading in PP2007 presentation is left-aligned
Summary: FILEOPEN: Centered heading in PP2007 presentation is left-aligned
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: high minor
Assignee: Xisco Faulí
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
: 81047 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-28 00:23 UTC by DarkWyrm
Modified: 2015-12-17 07:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File which demonstrates the bug (255.68 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-04-28 00:23 UTC, DarkWyrm
Details
Simple document created in Office 2010 (70.08 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-09-14 12:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DarkWyrm 2013-04-28 00:23:19 UTC
Created attachment 78564 [details]
File which demonstrates the bug

Problem description:
PowerPoint 2007 file opened in Impress: heading in title slide is not centered. Modifying the style for the box does not correct the alignment -- is left-aligned and should be centered.

Steps to reproduce:
1. Open attached file.
2. Note alignment of text 'Holmes Medical Center' which is properly centered when opened in PowerPoint 2007.

Current behavior:
Left-aligned

Expected behavior:
Centered

Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-04-30 03:22:44 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.5.4 -- using bibisect 
Platform: Bodhi Linux
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work but definitely can slow it down
High - common feature + interoperability

Keywords - 

Whiteboard Status - 

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 ign_christian 2014-07-08 15:14:36 UTC
*** Bug 81047 has been marked as a duplicate of this bug. ***
Comment 3 ign_christian 2014-07-08 15:20:19 UTC
I mark Bug 81047 as duplicate to this one since I saw same behavior with both files in header text:

Broken (left-aligned) in LO 3.6.7.2, 4.0.6.2, 4.1.6.2, 4.2.5.2, 4.3.0.2
Correct (center-aligned) in LO 3.5.7.2, AOO 4.1.0, Kingsoft 2013
Comment 4 Xisco Faulí 2014-08-06 16:32:25 UTC
This issue is still reproducible with:
Version: 4.4.0.0.alpha0+
Build ID: 58069f3676ab98b7383c11ff2fd1f17fa4522d77
Comment 5 Xisco Faulí 2014-08-07 08:45:58 UTC
d202b17d88ecb0b608d81518624021c832c7dfdb is the first bad commit
commit d202b17d88ecb0b608d81518624021c832c7dfdb
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Apr 25 07:28:24 2012 +0200

    source-hash-ce97851773a06103504972eb2771eecd7dd81e36
    
    commit ce97851773a06103504972eb2771eecd7dd81e36
    Author:     David Tardon <dtardon@redhat.com>
    AuthorDate: Mon Feb 6 19:12:02 2012 +0100
    Commit:     David Tardon <dtardon@redhat.com>
    CommitDate: Mon Feb 6 19:12:02 2012 +0100
    
        fix typo

:100644 100644 e1c1d62aa980fee004430f920cdbe3fd1ce79bf0 9acf11b8f6f5e26b03649767813ac42f72c38e1b M	autogen.log
:100644 100644 c14237a7b6ebde67a83585c9b057c78710e08ea2 db4232175b715b6c7f322b17041f56a9145e1622 M	ccache.log
:100644 100644 c407d12366338584cbcebf2197cd7fcdcf1c522b 1b83a94159f8aa22e004b5dc2ebe1895b32a2724 M	commitmsg
:100644 100644 3be616510b5296b5ae2f5c154a6c51f7ba49bf24 cc9f341a09ba536bb41d4219c5b7f5dd219d7cc6 M	dev-install.log
:100644 100644 637e789a93608b99c13fec9e598c2e7a4c454c6d 08ab33c46c34b7b9b0f8b7f21161ad1c1a2ed59a M	make.log
:040000 040000 c47ba9e6977c3c8a957b11ec3f8b85cfa50362af f87831ea583aaccb888e681ce264cc1e4e44d3aa M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# good: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect good 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# bad: [378efb6e51212a05d1bd4b85c916eec5753c1744] source-hash-d453788ac0476cc02b929b0907718ca771d6d956
git bisect bad 378efb6e51212a05d1bd4b85c916eec5753c1744
# bad: [1a3c4b54a8782fe0f4bdba221e87012a92e4d323] source-hash-a330f38093e2643a26239557050561afae9ff23d
git bisect bad 1a3c4b54a8782fe0f4bdba221e87012a92e4d323
# good: [cf86b7f14a98d2d81a5cd93507acb35ff6775d8b] source-hash-85c6244b85b29c1d2bb9d89b62e9512dd65378b5
git bisect good cf86b7f14a98d2d81a5cd93507acb35ff6775d8b
# good: [bc87fae0fc661b44769d71e41a0e8ce3dac3e857] source-hash-f176c9ba7be7f3051a52b9f57b56124038c0cfd6
git bisect good bc87fae0fc661b44769d71e41a0e8ce3dac3e857
# bad: [d202b17d88ecb0b608d81518624021c832c7dfdb] source-hash-ce97851773a06103504972eb2771eecd7dd81e36
git bisect bad d202b17d88ecb0b608d81518624021c832c7dfdb
# good: [9300cbe83880d09cc6d581eb73a92f35f3456b31] source-hash-43c7830b03d141ae11d8617c0fdabefa32dd243c
git bisect good 9300cbe83880d09cc6d581eb73a92f35f3456b31
# first bad commit: [d202b17d88ecb0b608d81518624021c832c7dfdb] source-hash-ce97851773a06103504972eb2771eecd7dd81e36
Comment 6 Xisco Faulí 2014-08-07 11:22:11 UTC
This issue was introduced by commit a71c878cd0b443a0d8473d8e4eb43d66f37ce2c0.
Adding "if ( rAttribs.hasAttribute( XML_algn ) )" fixes the issue. Besides, it doesn't revert http://www.libreoffice.org/bugzilla/show_bug.cgi?id=54565. However I don't know where to find n#744509's document, thus I can't test it. I add Muthu as a CC to see if he can take a look himself.
Comment 7 Muthu 2014-08-07 11:27:47 UTC
Thank you - will take a look.
Comment 8 Muthu 2014-08-25 05:55:50 UTC
For reference: Original test document @
https://bugzilla.novell.com/show_bug.cgi?id=744509
Comment 9 Muthu 2014-09-07 17:10:52 UTC
@Xisco: Sorry for the delayed reply: Your if(...) seems to not affect n#744509 - so, please go ahead and push it along with the unit test case (if possible). Thank you so much for the patch/work!

Assigning this to you - hope that's fine, please?
Comment 10 Xisco Faulí 2014-09-14 12:15:10 UTC
Yes, no problem, in fact I've investigated it a bit more and I found some interesting things:
The problem appears when we create a .pptx document ( works correctly if we save as .ppt ) using a default powerpoint theme containing a center-aligned title ( works correctly if it's right-aligned) like for instance 'civic' or 'black tie'. Reproduced with documents created either in Office 2007 or in Office 2010.
Comment 11 Xisco Faulí 2014-09-14 12:16:13 UTC
Created attachment 106255 [details]
Simple document created in Office 2010
Comment 12 Xisco Faulí 2014-10-20 09:12:35 UTC
It seems that the commit that caused this regression was identified. (Or at
least a commit is suspected as the offending one.)

Thus setting keyword "bisected".
Comment 13 Xisco Faulí 2015-08-19 09:45:13 UTC
This issue has been fixed by 7a64988dbc7a1542aa38f0e8f9a8a47941fbc67d.
Tested with Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)
Comment 14 Robinson Tryon (qubit) 2015-12-17 07:14:08 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]