Download it now!
Bug 64033 - libreoffice not getting focus when opened if closed with formatting window open
Summary: libreoffice not getting focus when opened if closed with formatting window open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-29 08:00 UTC by Paolo Benvenuto
Modified: 2017-05-23 08:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2013-04-29 08:00:17 UTC
Reproduce it:
- in libreoffice, open the styles and formatting window (F11)
- close libreoffice
- open nautilus/files, and open an odt file
  OR 
  run "libreoffice" from terminal and then, from LO, begin a new document
  OR
  run libreoffice with an odt doc as argument

Result: neither libreoffice main window nor style little windows have focus
Comment 1 Paolo Benvenuto 2013-04-30 08:21:00 UTC
Also when switching (with gnome alt-tab) to an open libreoffice instance with an open document and the style window visible: the user get the window visible but without focus
Comment 2 QA Administrators 2015-03-04 02:21:55 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-03-24 12:25:16 UTC
Never confirmed by QA, so setting to NEEDINFO.

Paolo: is this still a problem with LibO 4.4.x?
Comment 4 Paolo Benvenuto 2015-03-24 13:17:01 UTC
I can confirm it with 4.3.3.2 430m0(Build:2)
Comment 5 Buovjaga 2015-03-26 07:18:58 UTC
Could reproduce by launching LibO, undocking style window, closing LibO, reopening LibO, starting new document -> style window steals focus - unable to start writing without clicking document background first.

No focus problem with alt-tab.

Lowered priority as this is very minor and I guess it's pretty rare to use style window undocked these days with the sidebar.

Scientific Linux 7 64-bit with Gnome 3.

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 6 tommy27 2016-04-16 07:25:16 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:26:51 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.2.7 or 5.3.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170522