Bug Hunting Session
Bug 64089 - Conditional Color Formatting not applied on file open
Summary: Conditional Color Formatting not applied on file open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-30 16:17 UTC by Jon Hood
Modified: 2015-03-04 03:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
crazy stock portfolio.ods (23.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-30 16:17 UTC, Jon Hood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Hood 2013-04-30 16:17:08 UTC
Created attachment 78654 [details]
crazy stock portfolio.ods

When the sample spreadsheet (will attach) is opened, the conditional color format on column K is not applied. Scroll down to G:67 and change the value (ex: "31.21"). The conditional formatting then applies to column K, but will revert again once the document is saved and reopened.

NOTE: the sample spreadsheet uses the getquote() extension, as I tried to preserve what happened to reproduce the error: http://getquote-tedsoft.blogspot.com/2011/04/getquote-v11-released.html
Comment 1 Joel Madero 2013-04-30 21:03:47 UTC
Should it just be "$31.20", if so:

I can confirm the issue on 4.0.3.1 rc but it's fixed on 4.1 master. 

Please verify that it's just the $xx.xx that we should see, if so I will try to figure out what hasn't been back ported to 4.0 branch.
Comment 2 Jon Hood 2013-04-30 21:08:20 UTC
I'm not 100% sure on what you're asking me to verify? The only column that was not displaying the conditional color formatting that I noticed was column K; the monetary values shouldn't matter. In fact, changing any of the monetary values results in the conditional color formatting returning to column K. The monetary values are inconsequential to the test case.
Comment 3 Joel Madero 2013-04-30 23:23:17 UTC
Will test again - was focusing on G67 instead of column K ;)
Comment 4 Joel Madero 2013-05-01 02:39:00 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work - for instance if you make something with formatting and then send to someone else, they wouldn't be aware of the formatting
High - regression

cc'ing Markus - Markus I can confirm this is a minor release regression - works through bibisect (which I think means all the way up to 4.0.0.3 release)


Keywords - regression (works fine all the way through bibisect)


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 5 Jon Hood 2013-05-01 14:16:25 UTC
Well, this is part of a much larger spreadsheet, and I'm noticing other bugs as well. The calculated fields are not updating on load.

For example, observe row 20 as you open up the document. Column F indicates that the current value of this investment is $100.70, and column G indicates that the portfolio has 1 share. Column H is calculated as 100.70*1, but returns a value of $100.62.

Therefore, this bug isn't just about conditional formatting - it also fails to accurately calculate non-conditoinally-formatted fields on load.

Note that if the value of row 20's investment is $100.62 when you open the spreadsheet, you won't be able to see that there's an error. Since the sheet is simplified, observe columns F, G, and H. When H != F*G, this bug is reproduced.

I believe that these issues are related to bug #60215, and I apologize for the duplicate. Hopefully this will provide another test case for bug $60215, and the calculation errors may provide a hint for what's causing the issue. I will leave this up to the developers on whether or not to mark it as a true duplicate, since bug #60215 does not contain information about the calculation errors.
Comment 6 QA Administrators 2015-03-04 02:18:41 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Jon Hood 2015-03-04 03:19:56 UTC
This appears fixed in Libreoffice 4.3.5.2 (all platforms).