Download it now!
Bug 64113 - EDITING: Field contextual menu is not always correctly displayed
Summary: EDITING: Field contextual menu is not always correctly displayed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-01 14:24 UTC by Yann Papouin
Modified: 2015-03-22 11:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Input field included with screenshot (48.41 KB, application/vnd.oasis.opendocument.text)
2013-05-01 14:24 UTC, Yann Papouin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yann Papouin 2013-05-01 14:24:00 UTC
Created attachment 78722 [details]
Input field included with screenshot

Problem description: 

If you try to display the contextual menu of a field by clicking on the right part (opposite to left) of the field, then the "Fields ..." action that open the field editor dialog is missing in the menu.

(see file attached, the part is red cannot be used for a right click)

Expected behavior:

The contextual menu must be always valid when right-cliking on the "gray" hit box part of the field.

(note that it also happend on Windows 7)
Operating System: Windows 8
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-05-01 17:37:48 UTC
Yann - in the future please provide explicit steps to reproduce bugs - even if it seems straight forward number the steps for instance:

1. Open writer
2. insert field
3. Right click on the right side of the field

etc.. etc..

Trying to confirm this one now, guessing at the steps a bit
Comment 2 Jorendc 2013-05-02 14:31:08 UTC
Heh, nice catch there!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice Version 4.0.3.2 (Build ID: c6786add5a58268e11aa027c47054344040db1b).

What I did: 
* open the attached test document (Attachment 78722 [details])
* Right click on the *left half* of the grey field box

Behavior: menu entry 'Fields...' is visible

* Right click on the *right half* of the grey field box

Behavior: menu entry 'Fields...' dissipated.

Priority:
* Minor: makes working with fields sustainable harder if you don't know this behavior
* Medium: default for minor bugs.

Kind regards,
Joren
Comment 3 QA Administrators 2015-03-04 02:18:14 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 4 Buovjaga 2015-03-22 11:21:23 UTC
Fields is now visible even when clicking the right side.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI