Download it now!
Bug 64146 - Inserting file containing a numbered list messes up numbering
Summary: Inserting file containing a numbered list messes up numbering
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Insert-File-Content
  Show dependency treegraph
 
Reported: 2013-05-02 12:54 UTC by Lionel Dricot
Modified: 2019-09-10 10:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test document to demonstrate bug (7.44 KB, application/vnd.oasis.opendocument.text)
2013-05-02 12:54 UTC, Lionel Dricot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Dricot 2013-05-02 12:54:16 UTC
Created attachment 78776 [details]
test document to demonstrate bug

This bug was first filled against OpenOffice: https://issues.apache.org/ooo/show_bug.cgi?id=109113


Steps to reproduce:

Step 1: Open attached file insert_numbering_bug.odt. The file contains the
following numbered list:
  1. One
  2. Two
  3. Three
  4.

Step 2: Move cursor to "4."
Step 3: Use "Insert->File..." to insert the file insert_numbering_bug.odt.

The result is the following list:
  
  1. One
  2. Two
  3. Three
  4. One
  1. Two
  2. Three
  5. 

This is obviously not what you would expect. Especially the "5." at the end.
Comment 1 Jorendc 2013-05-02 13:50:23 UTC
Hi,

Thanks for reporting. I'm not sure it was you, but someone already asked this on the libreoffice-dev channel to test with LibreOffice.

Since I reproduced that bug already, I'm going to mark it as such. Reproduced using Linux Mint 14 x64 with LibreOffice Version 4.0.3.2 (Build ID: c6786add5a58268e11aa027c47054344040db1b) and Version: 4.1.0.0.alpha0+
Build ID: a514c72071a4e572bb712f78b8b119ed0b2eb6b

Probably reproducible with first version of LibreOffice, due the fact the bug is also reported against AOO.

Priority:
* Minor: does make it substantially harder to make high quality work
* High: a bit more priority then default.

Kind regards,
Joren
Comment 2 QA Administrators 2015-03-04 02:23:31 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-03-24 17:04:18 UTC
Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 4 tommy27 2016-04-16 07:23:55 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-05-22 13:24:24 UTC Comment hidden (obsolete)
Comment 6 Carlo 2017-08-14 13:37:52 UTC
Reproduced.

Versione: 5.4.1.1 (x64)
Build ID: a5be49f0c45fe24a575c7f41559aa8fc79a781a2
Thread CPU: 8; SO: Windows 6.19; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT); Calc: group
Comment 7 QA Administrators 2018-08-15 02:33:26 UTC Comment hidden (obsolete)
Comment 8 Timur 2019-09-10 10:41:21 UTC
Repro 5.4 (Insert-Document). No repro 6.2 and 6.4+. WFM