Bug 64166 - UI Colors do not play very nice with dark background
Summary: UI Colors do not play very nice with dark background
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-02 19:00 UTC by Luiz Angelo Daros de Luca
Modified: 2015-03-24 12:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
startup page (text too white) (43.44 KB, image/png)
2013-05-02 19:00 UTC, Luiz Angelo Daros de Luca
Details
Menu disabled items too dark (14.18 KB, image/png)
2013-05-02 19:03 UTC, Luiz Angelo Daros de Luca
Details
Dialog text uses wrong color (16.86 KB, image/png)
2013-05-02 19:04 UTC, Luiz Angelo Daros de Luca
Details
Some dialogs works flawlessly. No colors problem (50.78 KB, image/png)
2013-05-02 19:06 UTC, Luiz Angelo Daros de Luca
Details
Example of good disabled menu color (25.89 KB, image/png)
2013-05-02 19:06 UTC, Luiz Angelo Daros de Luca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luiz Angelo Daros de Luca 2013-05-02 19:00:17 UTC
Created attachment 78791 [details]
startup page (text too white)

Hello,

Libreoffice, at least the kde4 integrated interface, uses wrong colors for some dialogs, menu and startup page. I'll attach the screnshots.

Generally, the problem is that it uses "view text" color on a panel that uses "window background" color. The correct color would be "Window Text". "View Text" is to be used in conjunction with "View Background", as in any input component.

Also, the disabled menu items should use a lighter color, as kde menu does. I don't know which color they choose.

I'm using OpenSuSE 12.3 with KDE OpenSuSE Dark Theme.
Comment 1 Luiz Angelo Daros de Luca 2013-05-02 19:03:30 UTC
Created attachment 78792 [details]
Menu disabled items too dark
Comment 2 Luiz Angelo Daros de Luca 2013-05-02 19:04:05 UTC
Created attachment 78793 [details]
Dialog text uses wrong color
Comment 3 Luiz Angelo Daros de Luca 2013-05-02 19:06:05 UTC
Created attachment 78794 [details]
Some dialogs works flawlessly. No colors problem
Comment 4 Luiz Angelo Daros de Luca 2013-05-02 19:06:33 UTC
Created attachment 78795 [details]
Example of good disabled menu color
Comment 5 Adolfo Jayme 2013-05-06 02:40:30 UTC
Related: bug 50921.
Comment 6 QA Administrators 2015-03-04 02:21:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Buovjaga 2015-03-24 12:56:34 UTC
I think after this report was submitted, the behavior was changed. Now nothing is dark in LibO with a dark theme in openSUSE 13.2. Setting to WFM.

LibreOffice
Version: 4.4.2.1
Build ID: 93fc8832889bf050a10ec6d0171dae213adc9b55
Locale: en_US