Download it now!
Bug 64239 - FILESAVE: lines not saved correctly after opened from Power Point / lines not possible to delete on slides
Summary: FILESAVE: lines not saved correctly after opened from Power Point / lines not...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-05 15:25 UTC by Ljiljan
Modified: 2016-05-07 07:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Drawing objects not shown correctly (imported from Power point) and how it should look (drawn in LibreOffice). Lines are not possible to delete. (24.90 KB, application/vnd.oasis.opendocument.presentation)
2013-05-05 15:25 UTC, Ljiljan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2013-05-05 15:25:47 UTC
Created attachment 78881 [details]
Drawing objects not shown correctly (imported from Power point) and how it should look (drawn in LibreOffice). Lines are not possible to delete.

Problem description: 

Presentation was created in Power Point 2007. LibreOffice opened it perfectly (no mistakes). After saving it in LibreOffice format, some lines are not showing correctly and it is not possible to remove those lines and to draw them again in LibreOfffice. 

Steps to reproduce:
1. Draw lines as attached in Power Point using Free Form tool
2. Save presentation 
3. Open it in LibreOffice Impress
4. Save it in LibreOffice Impress format
5. Open it again in LibreOffice 

Current behavior:

Expected behavior:

              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 ign_christian 2013-05-14 15:33:50 UTC
I also see weird behaviour of red lines on slide 1 & slide 3 if I'm saving the attached file as .ppt (red lines disappear) or .pptx (red lines forming rectangles). 

Tested using LO 4.0.3.3 with Win7 32bit
Comment 2 QA Administrators 2015-03-04 02:21:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 3 Ljiljan 2015-03-04 07:18:11 UTC
I tested this bug again. 

Now, the situation is much better although some problems still exists.

Good things:

- The lines are possible to delete
- Saving in ODP, PPT and other formats does not change the existing shapes.

However

- There is "infinite" line on first and third slide... it's possible that these lines would never appear in LO 4.4, but they were somehow created in LO 4.0 and they still exist. Therefore, it is possible that this line would never existed if LO 4.4 was used.
- "infinite" line can be deleted, but cannot be re-sized. 


---------
* "infinite" line does not have beginning or ending :)
Comment 4 Jean-Baptiste Faure 2015-03-16 05:55:14 UTC
(In reply to Ljiljan from comment #3)
[...]
> However
> 
> - There is "infinite" line on first and third slide... it's possible that
> these lines would never appear in LO 4.4, but they were somehow created in
> LO 4.0 and they still exist. Therefore, it is possible that this line would
> never existed if LO 4.4 was used.
> - "infinite" line can be deleted, but cannot be re-sized. 

You should attach the original PPT file to test the import with current stable versions.

Note: it seems that the "infinite" lines are not lines. Indeed when you select one you get a rectangular selection. It is different when you select a line drawn in Impress.

Best regards. JBF
Comment 5 tommy27 2016-04-16 07:26:56 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 6 Jean-Baptiste Faure 2016-05-06 16:02:40 UTC
Please attach the original PPT file.

Best regards. JBF
Comment 7 Ljiljan 2016-05-06 21:13:12 UTC
I don't have original file anymore (or if I have it I cannot find it anymore).

However, in LibreOffice 5.1. the red line can be deleted or reduced.
Comment 8 Jean-Baptiste Faure 2016-05-07 07:57:52 UTC
(In reply to Ljiljan from comment #7)
> I don't have original file anymore (or if I have it I cannot find it
> anymore).
> 
> However, in LibreOffice 5.1. the red line can be deleted or reduced.

Indeed the bad imported line can be deleted in LO 5.1 and the master.

Closing as Resolved/InsufficientData because we can't go further without the original ppt source file. Please feel free to reopen if you recover this file.

Best regards. JBF