Bug 64333 - [Template Manager] [UI]: Overwriting an existing template with a new one, demands that the name is typed; should be picked up by selecting the existing template
Summary: [Template Manager] [UI]: Overwriting an existing template with a new one, dem...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-07 20:00 UTC by severoraz
Modified: 2016-06-24 20:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description severoraz 2013-05-07 20:00:19 UTC
Problem description:
To save a template over itself (i.e. edit it) one has to type out its exact name all over.

Steps to reproduce:
1. Open a blank document
2. Save it as a template (File > Save as template)
3. Chose any folder, e.g. My Templates
4. Click on Save

Current behavior:
A text box appears so you enter the file name. If you have an existing template selected and click on Save, you still get the text box.

Expected behavior:
If you have an existing template selected and click on Save, it should be interpreted by LibreOffice as a replace action request and act duly.
              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-05-08 13:54:09 UTC
Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice Version: 4.1.0.0.alpha1+ Build ID: 94fdd5d302e34220a0b1beaf3610658d15c7b80

A workaround is not to select > save it but just hit the 'save' button and type the name. Then it'll ask:

A template named save already exist in My Templates. Do you want to overwrite it?YES NO 

But ... this is buggy too. I doesn't replace the old template, but just create another one with the same name. But that's another bug (other part of code). This bug is about the ability about 'select a template' > 'save' -> save it as the selected template.

Kind regards,
Joren
Comment 2 Cor Nouws 2013-05-10 08:55:39 UTC
I may be dump, but I don't get the issue :-)

(In reply to comment #0)
> Problem description:
> To save a template over itself (i.e. edit it) one has to type out its exact
> name all over.

- go to File > New > Templates
- select template
- choose edit
- change the template and hit save
Done. 
It just saves as any other file, under the existing file name.


> Expected behavior:
> If you have an existing template selected and click on Save, it should be
> interpreted by LibreOffice as a replace action request and act duly.

Pls try to make me understand how you can avoid that behaviour...
thanks,
Comment 3 Jorendc 2013-05-10 09:17:02 UTC
(In reply to comment #2)
> I may be dump, but I don't get the issue :-)

No you are not. I had to read it also multiple time (no offence Bug Reporter ;-) ).

The problem is: you have to retype the name of the template which you want to overwrite ( = give it the same name and overwrite it). The bug reporter suggests that: "click on the template you would like to overwrite" -> Hit 'Save' -> Saved as that template.

I think this is also the behavior in "save (as)" dialogs? Select the file which you would like to overwrite -> save ... file saved as the file which you would like to overwrite (not by retyping the whole name).

Kind regards,
Joren
Comment 4 Cor Nouws 2013-05-10 11:50:22 UTC
Still being dumb...

(In reply to comment #3)

> The problem is: you have to retype the name of the template which you want
> to overwrite ( = give it the same name and overwrite it). The bug reporter
> suggests that: "click on the template you would like to overwrite" -> Hit
> 'Save' -> Saved as that template.

Why should I need to overwrite a template, that I edit, with the same name?
File > Save / Ctrl-S just work fine.

/ still puzzled
Comment 5 Jorendc 2013-05-10 12:06:16 UTC
What if you would like to create a new template (or open a file) which you would like to replace an existing template? :-) In that case you didn't opened it by using the template manager.

Kind regards,
Joren
Comment 6 Cor Nouws 2013-05-10 12:31:12 UTC
(In reply to comment #5)
> What if you would like to create a new template (or open a file) which you
> would like to replace an existing template? :-) In that case you didn't
> opened it by using the template manager.


Top of the report: " To save a template over itself (i.e. edit it) one has to type out its exact name all over. " 

So it's not clear .., or rather wrong workflow from the user.

When the OP means saving a new document as template and overwriting an existing template... then indeed it's needed to type the name, which is not needed in case of a normal Save As.
But the OP does not write that ...
(And by the way: overwriting an existing template ... looks not so solid too)
Comment 7 severoraz 2013-05-11 03:49:40 UTC
(In reply to comment #6)
> When the OP means saving a new document as template and overwriting an
> existing template... then indeed it's needed to type the name, which is not
> needed in case of a normal Save As.
> But the OP does not write that ...
> (And by the way: overwriting an existing template ... looks not so solid too)

Oh well, I never saw that edit option. It is right I am reporting a bug from the perspective of a user using a wrong workflow. We all recognize that, but I still believe that the save-over-existing-template functionality should also be available from the template manager. As others have said, there can be cases thought of where this would be important.

Sorry if I made the report difficult to understand, I am glad it is know clear to everybody what I meant.
Comment 8 Cor Nouws 2013-05-12 10:44:43 UTC
@wolterh
thanks for your additional explanation.
I change the summary of the issue to reflect the current idea.
Comment 9 bejectannt 2014-01-16 02:10:59 UTC
I just wanted to report the same (also not knowing the template manager's edit function). However, it really may be that one wants to replace a template with a new one. 

In addition, the "current" behaviour is a bit different (and worse) for me (version 4.1.4.2 on archlinux). The new template does not get saved at all (and no textbox appears, as described in the original report here), which meant lost work to me.

0. have a document template in your "my templates"
1. make a new text document, with blablablabbalablaaa content
2. menu File → "save as template"
3. click a existing template (it may be the intention to overwrite this template with the current document or just an accidental click)
4. click save

results: nothing (no save, anywhere, apparently)

expected: it is asked if the selected template should be overwritten AND the current document is saved as template.
Comment 10 Samuel Mehrbrodt (CIB) 2016-06-17 09:20:40 UTC
I think this is "fixed" with the revamped template manager. The workflow changed, so it's no longer possible to select a template; you can only select a category.

Please reopen if the problem persist.
Comment 11 bejectannt 2016-06-17 20:54:45 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> I think this is "fixed" with the revamped template manager. The workflow
> changed, so it's no longer possible to select a template; you can only
> select a category.
> 
> Please reopen if the problem persist.

Sorry, with 5.1.3.2 I can still reproduce as mentioned in comment 9. In which version is the "revamped template manager"? I could not find it in the release notes of the current dev release.
Comment 12 Samuel Mehrbrodt (CIB) 2016-06-20 07:39:42 UTC
(In reply to bejectannt from comment #11)
> Sorry, with 5.1.3.2 I can still reproduce as mentioned in comment 9. In
> which version is the "revamped template manager"? I could not find it in the
> release notes of the current dev release.

The changes are in 5.2 and 5.3. The release notes section is still missing.
Can you please test with these versions?
Comment 13 bejectannt 2016-06-24 20:21:23 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #12)
> The changes are in 5.2 and 5.3. The release notes section is still missing.
> Can you please test with these versions?

Thanks for the version info! It is good to know in which version one can expect to see the "fixed" behaviour.

No, sorry, I cannot test that easily with those versions (not available in official repos of archlinux and .deb or .rpm is of no help and building self is much effort).

Thank you for your work!