Bug Hunting Session
Bug 64367 - FORMATTING: Calc fails transforming galician month's names in format DMY
Summary: FORMATTING: Calc fails transforming galician month's names in format DMY
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-08 16:31 UTC by Antón Méixome
Modified: 2013-05-15 09:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antón Méixome 2013-05-08 16:31:34 UTC
Problem description: 

Calc not recognize month's names in galician when importing a list of ítems. Only recognize the names been the same for english. In import dialog you can set the language for import but Calc is not interpreting correctly.

Steps to reproduce it:

1. Look at this serie

1 Xan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 Mai, 2012
6 Xuñ, 2012
7 Xul, 2012

You have the items in a txt document, without formating. Then, you copy the serie and paste it inside a cell of Calc. Calc open import dialog. Set the galician language. Set the type of data fron «Standard» to DMA (interface in english=DMY). 


Current behavior:

1 Xan, 2012
02/02/12
03/03/12
4 Abr, 2012
5 Mai, 2012
6 Xuñ, 2012
7 Xul, 2012

My actual default format for data is DD/MM/YY

Expected behavior:

01/01/12
02/02/12
03/03/12
04/04/12
05/05/12
06/06/12
07/07/12

I was testing if this is reproducible in spanish or portuguese and not. It's only for galician names and in various versions. I don't know when this behavior appeared.

Otherwise, I find a related question and I think this would be improved.
If you have a list with errors in names (e.g. if you merge names in different languages or having misspelled words or the abreviations are inexact) Calc accept if matching the english forms.

e.g.
Serie en portuguese with errors

1 Jan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 May, 2012
6 Jun, 2012
7 Jul, 2012

seen in Calc

01/01/12
02/02/12
03/03/12
04/04/12
05/05/12
06/06/12
07/07/12

Calc transforms it correctly, even when there are some errors (Feb→Fev; May→Mai)
but, ... these "errors" matchs with english forms...

Reverse ? No, of course. Look

Serie for english with "errors" in portuguese

1 Jan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 Mai, 2012
6 Jun, 2012
7 Jul, 2012

Results

01/01/12
02/02/12
03/03/12
4 Abr, 2012
5 Mai, 2012
06/06/12
07/07/12

This is the probe. Calc refuse admits in english "Abr" or "Mai" but
accepts "Feb" or "May" in portuguese.

What's the improve? 
If you set the import language to "x" for a dataset Calc must refuse perform a inaccurate filter with other language.

Of course, the bug is prior!





              
Operating System: All
Version: unspecified
Comment 1 m.a.riosv 2013-05-08 21:45:46 UTC
Hi Antón, saúdos, thanks for reporting,

Reproducible with:
Win7x64 Ultimate.
LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1
Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
Version: 4.1.0.0.alpha0+Build ID: 4c4b9db8bbaed7acd064a4015fabe784c4fbca2 TinderBox: Win-x86@6, Branch:master, Time: 2013-04-28_06:18:09

No success changing the separator:
1.Xan.2012
1-Xan-2012
1/Xan/2012
the issue remains.

But the issue it is not there with the complete month name.

Maybe some list of abbreviations in Galician was left without translation.
Comment 2 Antón Méixome 2013-05-09 08:27:38 UTC
Still reproducible on Debian (Guadalinex v7) and
OpenOffice 3.2.0 OOOm320m12 (Build:9483)

Though this bug it's OS independent and UI language independent.
Comment 3 Antón Méixome 2013-05-09 09:28:49 UTC
(In reply to comment #1)
> Hi Antón, saúdos, thanks for reporting,
> 
> Reproducible with:
> Win7x64 Ultimate.
> LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1
> Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
> Version: 4.1.0.0.alpha0+Build ID: 4c4b9db8bbaed7acd064a4015fabe784c4fbca2
> TinderBox: Win-x86@6, Branch:master, Time: 2013-04-28_06:18:09
> 
> No success changing the separator:
> 1.Xan.2012
> 1-Xan-2012
> 1/Xan/2012
> the issue remains.
> 
> But the issue it is not there with the complete month name.
> 
> Maybe some list of abbreviations in Galician was left without translation.


Hi, mariosv

Thanks for confirm. Also Sérgio (Portuguese) and Sophie (Frances) confirm this issue.

Maybe that are you saying, but with UI translated to 100%. Where is hide the list/s of abreviations?

e.g. Jan → Xan in Pootle

https://translations.documentfoundation.org/gl/libo_ui/sw/source/ui/app.po/translate/#unit=29543374

https://translations.documentfoundation.org/gl/libo_ui/sc/source/ui/src.po/translate/#unit=29529084

Specially the last one has a "Context:
autofmt.src RID_SCDLG_AUTOFORMAT STR_JAN string.text"

so others

"RID_SCDLG_AUTOFORMAT\n"
"STR_FEB\n"

"RID_SCDLG_AUTOFORMAT\n"
"STR_MAR\n"


They are translated but


Where is the english strings for Apr, May, Jun, Jul, Aug, Oct, ? Maybe they are not accesible for translate?
Comment 4 m.a.riosv 2013-05-09 10:31:42 UTC
Looking where to find something, I have found this file:
https://gerrit.libreoffice.org/gitweb?p=core.git;a=blob;f=i18npool/source/localedata/data/gl_ES.xml

If it is used for the day and month names interpretation:
...
> 196   <LC_COLLATION ref="en_US" />
> 197   <LC_SEARCH ref="en_US"/>
> 198   <LC_INDEX ref="es_ES"/>
                       ----- maybe gl_ES?   
> 199   <LC_CALENDAR>
> 200     <Calendar unoid="gregorian" default="true">
> 201       <DaysOfWeek>
> 202         <Day>
> 203           <DayID>sun</DayID>
> 204           <DefaultAbbrvName>dom.</DefaultAbbrvName>
                                  ---? 
> 205           <DefaultFullName>domingo</DefaultFullName>
> 206         </Day>
....
> 237       </DaysOfWeek>
> 238       <MonthsOfYear>
> 239         <Month>
> 240           <MonthID>jan</MonthID>
> 241           <DefaultAbbrvName>xan.</DefaultAbbrvName>
                                  ---? 
> 242           <DefaultFullName>xaneiro</DefaultFullName>
> 243         </Month>

But trying with   1 Xan., 2012  does not work, does not seem the point after abbreviation is the matter.

The same issue with OpenOffice 3.4.1
Comment 5 Antón Méixome 2013-05-09 11:52:28 UTC
(In reply to comment #4)
> Looking where to find something, I have found this file:
> https://gerrit.libreoffice.org/gitweb?p=core.git;a=blob;f=i18npool/source/
> localedata/data/gl_ES.xml

Good point!

> 
> If it is used for the day and month names interpretation:
> ...
> > 196   <LC_COLLATION ref="en_US" />
> > 197   <LC_SEARCH ref="en_US"/>
> > 198   <LC_INDEX ref="es_ES"/>
>                        ----- maybe gl_ES?   

I think not. In fact the spanish file only has  <LC_SEARCH ref="en_US"/> no more. I don't know why the galician has this reference to spanish index.


> > 199   <LC_CALENDAR>
> > 200     <Calendar unoid="gregorian" default="true">
> > 201       <DaysOfWeek>
> > 202         <Day>
> > 203           <DayID>sun</DayID>
> > 204           <DefaultAbbrvName>dom.</DefaultAbbrvName>
>                                   ---? 
> > 205           <DefaultFullName>domingo</DefaultFullName>
> > 206         </Day>
> ....
> > 237       </DaysOfWeek>
> > 238       <MonthsOfYear>
> > 239         <Month>
> > 240           <MonthID>jan</MonthID>
> > 241           <DefaultAbbrvName>xan.</DefaultAbbrvName>
>                                   ---? 
> > 242           <DefaultFullName>xaneiro</DefaultFullName>
> > 243         </Month>
> 
> But trying with  Xan., 2012  does not work, does not seem the point after
> abbreviation is the matter.
> 

I can confirm it. Previously I have perform with some alternatives too but, nothing succesfull.

> The same issue with OpenOffice 3.4.1

Probably this is a very old issue on the history of de code OpenOffice.org. Now it came visible.

The galician version vs. spanish version of this file has subtle differences:

Spanish has

 198	<LC_INDEX>
 199     <IndexKey phonetic="false" default="true" unoid="alphanumeric">A-N Ñ O Ó P-Z</IndexKey>
 200     <UnicodeScript>0</UnicodeScript>
 201     <UnicodeScript>1</UnicodeScript>
 202     <FollowPageWord> s.</FollowPageWord>
 203     <FollowPageWord> ss.</FollowPageWord>
 204   </LC_INDEX>

but galician has not nothing equivalent.

Galician
<Locale versionDTD="2.0.3" allowUpdateFromCLDR="no" version="1.3">

Spanish
<Locale versionDTD="2.0.3" allowUpdateFromCLDR="no" version="1.2">

The case is: IMHO this file isn't the basic problem. This file shows the galician options for autofill and sorting lists. I'm convinced the problem is something as AUTOFORMAT where galician forms are not active.

It's near,
Comment 7 Eike Rathke 2013-05-15 09:25:07 UTC
Indeed, I was about to do the same.