Download it now!
Bug 64403 - LibreOffice Calc cannot open document without explicit cell indexes
Summary: LibreOffice Calc cannot open document without explicit cell indexes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-09 21:26 UTC by Jon Hood
Modified: 2015-03-04 03:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice_bugreport.xlsx (8.01 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-05-09 21:26 UTC, Jon Hood
Details
ExcelReport.cs (41.64 KB, text/plain)
2013-05-09 21:29 UTC, Jon Hood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Hood 2013-05-09 21:26:49 UTC
Created attachment 79065 [details]
libreoffice_bugreport.xlsx

LibreOffice does not display cells without an explicit rowindex and cellindex, while Microsoft Office correctly displays the generated spreadsheet and verifies it as valid.

Attached you will find the sample generated file (libreoffice_bugreport.xlsx) and the code used to generate it (using OpenXML SDK 2.0). The spreadsheet is reported as valid in the OpenXML SDK productivity tool, and opens correctly in Microsoft Office. The text in cell A1 displays "test". In LibreOffice, the text in cell A1 is empty.

Reproduction:
1. Open the sample .xlsx document in LibreOffice.
2. If cell A1 is empty, the bug is repeated.
3. Open the sample .xlsx document in Microsoft Office.
4. Cell A1 contains the text "test".

[optional]
5. Open the .xlsx file in the OpenXML SDK 2.0 Productivity Tool
6. Click the "validate" button to see that Microsoft sees the generated spreadsheet as valid OpenXML.

Attachments:
1. libreoffice_bugreport.xlsx: spreadsheet displaying the bug.
2. ExcelReport.cs: sample report generation using OpenXML SDK 2.0 from Microsoft without row and cell indexes
Comment 1 Jon Hood 2013-05-09 21:29:34 UTC
Created attachment 79066 [details]
ExcelReport.cs

This code requires OpenXML SDK 2.0 and was invoked as follows:

BuildDocument bd = new BuildDocument();
bd.CreatePackage("c:\\libreoffice_bugreport.xlsx");

to create the generated report at c:\libreoffice_bugreport.xlsx.

PLEASE NOTE: This C# code is NOT part of the bug report. It is simply provided so that you can see how a report can be generated that is valid OpenXML, works in Microsoft Office, and does not work in LibreOffice.
Comment 2 Joel Madero 2013-05-10 18:21:25 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.1.0.0.alpha1+Build ID: ed8f9ec2caa8485691999e5565a79e451e1dcb
Date:   Wed May 8 18:48:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work, document cannot be viewed correctly at all
High - very basic document, seems like it could be a root of a more serious issue


cc'ing Markus - any thoughts on this one, very very basic document opening incorrectly

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Markus Mohrhard 2013-05-10 18:26:15 UTC
This syntax is not supported by Calc. But I thought we transform it to explicit col+row references during import. Maybe something screwed this up or it never worked.

Would need to check it but won't be able to do that before the feature freeze.
Comment 4 QA Administrators 2015-03-04 02:18:00 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 5 Jon Hood 2015-03-04 03:17:22 UTC
This appears fixed in 4.3.5.2.