Download it now!
Bug 64422 - FILESAVE: Export to html ignore the capital font's effect.
Summary: FILESAVE: Export to html ignore the capital font's effect.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Paul Chavent
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-10 10:15 UTC by Paul Chavent
Modified: 2015-03-22 13:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Implement text-transform in the xhtml export. (1.08 KB, patch)
2013-05-10 12:50 UTC, Paul Chavent
Details
Sample of Caps Working Correctly in Styles + html (796 bytes, text/html)
2013-05-10 17:23 UTC, Joel Madero
Details
This file doesn't export correctly (23.40 KB, application/vnd.oasis.opendocument.text-flat-xml)
2013-05-10 20:01 UTC, Paul Chavent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Chavent 2013-05-10 10:15:41 UTC
Problem description: 
A text with capital font's effect style isn't uppercase when exported to html.

Steps to reproduce:
1. Enter a lower case text.
2. Create a style from the default one with "+ Caps" (Font effect -> Effects -> Capitals).
3. Apply the style to the text.
4. Export to html.

Current behavior:
The text is lower case.

Expected behavior:
The text is upper case.

The css "transform:uppercase" attribute is supported by all the major browser. It could be the solution.
              
Operating System: Linux (Other)
Version: 4.0.0.3 release
Comment 1 Paul Chavent 2013-05-10 12:50:40 UTC
Created attachment 79098 [details]
Implement text-transform in the xhtml export.

The patch implements the conversion of fo:text-transform.
Comment 2 Joel Madero 2013-05-10 17:22:37 UTC
I cannot confirm this behavior with 4.0.2.2 release

Attaching document which I created using the caps style in character styles

Marking as WFM.

@Paul - please test with 4.0.2.2 release or even on 4.0.3.3 rc, if you still see the problem, mark the bug as UNCONFIRMED (you may have to set to NEEDINFO first, apologies for this) and I will reinvestigate
Comment 3 Joel Madero 2013-05-10 17:23:06 UTC
Created attachment 79111 [details]
Sample of Caps Working Correctly in Styles + html
Comment 4 Paul Chavent 2013-05-10 20:01:19 UTC
Created attachment 79121 [details]
This file doesn't export correctly

This file doesn't export correctly to html (File->Export->XHTML) with 4.0.3.3.
Comment 5 Joel Madero 2013-05-10 20:02:16 UTC
REOPENED is only if a bug is marked as FIXED by a developer - and thus assigned the developer. Marking as UNCONFIRMED
Comment 6 Paul Chavent 2013-05-10 20:05:30 UTC
(In reply to comment #3)
> Created attachment 79111 [details]
> Sample of Caps Working Correctly in Styles + html

You generate this html with File->Save As->html

The bug is with the File->Export->xhtml procedure.
Comment 7 Joel Madero 2013-05-10 20:10:03 UTC
ah, thanks for the info there - with that:

I have been able to confirm the issue on:
Version: 4.1.0.0.alpha1+Build ID: ed8f9ec2caa8485691999e5565a79e451e1dcb
Date:   Wed May 8 18:48:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality/professional work
Medium - tempted to mark as low as it's not a very popular feature but...leaving as default medium.


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 8 QA Administrators 2015-03-04 02:20:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 9 Buovjaga 2015-03-22 13:20:43 UTC
(In reply to Paul Chavent from comment #4)
> Created attachment 79121 [details]
> This file doesn't export correctly
> 
> This file doesn't export correctly to html (File->Export->XHTML) with
> 4.0.3.3.

Exports correctly now:

<style media="all" type="text/css">
      body {font-family:'Liberation Serif',serif;font-size:16.0px}
      p.Standard {margin-left:0;margin-right:0;margin-top:0;margin-bottom:0;border:none;padding:0;font-size:16.0px}
      p.TestStyle {margin-left:0;margin-right:0;margin-top:0;margin-bottom:0;border:none;padding:0;font-size:16.0px;text-transform:uppercase}
    </style>

Setting to WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI