Download it now!
Bug 64477 - XY (Scatter) Chart - Data Ranges cannot be extended beyond last empty cell
Summary: XY (Scatter) Chart - Data Ranges cannot be extended beyond last empty cell
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-11 17:41 UTC by Steffen
Modified: 2016-09-20 09:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (43.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-12 04:53 UTC, Bugcruncher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 2013-05-11 17:41:30 UTC
XY Plot - Data Ranges cannot be extended beyond last non-empty cell.

I want to create a plot that will include new points added in the future. However LibreOffice keeps modifying my chosen ranges to the last existing datapoint. I have to add a dummy point to work around this.

Please see attached video of the problem for more details.
Comment 1 Steffen 2013-05-11 18:44:36 UTC
Failed to add video, its on youtube instead: http://www.youtube.com/watch?v=6nhS75V6O2I
Comment 2 David Wells 2013-06-08 09:56:15 UTC
I see the same problem having just moved from an old version of OpenOffice to Libre Office Version 3.6.6.2 (Build ID: 3.6.6.2-8.fc18).

As noted a work around is to add dummy data. Having played with this a bit I notice:

i) If I have two columns of data with column 1 being a label then I only need to add data to column 1 for the graph to change the data range to include up to the last data entry in column 1 - even if the entries in column 2 are empty. Note - I have set the treatment of empty cells to be as per Calc A1 which may influence what happens.

ii) You do not need to set data in all cells in column 1 in order for the graph data range to be extended just the cell that you want to be the end of the range. So, if I have data in rows 1 to 1000 and want the graph to have a data range from 1 to 1500 as additional data will be added to the last 500 rows later I only need to put data in the cell in row 1500. The chart will then set the data range to 1 to 1500.

iii) Once the chart data range has been set you can delete the dummy data from the cell (i.e cell 1500) and it doesn't seem to affect the chart data range which stays set.

I suspect this may be an issue that is philosophically related to the whole "how to handle and empty cell" discussion that seems to have been resolved by the addition of the

option > libre office calc > formula > detail calculation setting > custom 

setting. What Libre office is doing by default i.e not allowing the data range to be set beyond the last data point is consistent with the view that empty cells are not treated as having any value. If you set the behaviour to be like OO or Excel where an empty cell can be treated as a value of 0 then the current behaviour is inconsistent and breaks existing sheets/graphs.

So, maybe the fix is to have the behaviour depend on the above setting with the current behaviour applying if a purist view of an empty cell is taken and behaviour that allows the data range to include empty cells for compatibility if the empty cell behaviour is set to match OO or Excel.
Comment 3 David Wells 2013-06-08 10:00:39 UTC
Additional note to earlier comment.

If you delete the dummy data then next time the cell contents are re-calculated the chart data range will be reset to the end of the existing data. So, despite my earlier comment you need to leave the dummy data in the last cell you want the range to include.
Comment 4 Bugcruncher 2013-07-12 04:52:53 UTC
I also observe that problem with 4.0.3 on WIN, and I agree with  David Wells' analysis. 
That definitively was not a problem with LibreOffice 3.3.3 (I tried a portable Version).

The current behavior really is a painful if you have prepared a Spreadsheet for measurement values or similar, as you can see in attached sample document.

If you open it with AOO you will see that the data range is defined until Row 42, and you can add new measurement values for later times easily.

Working with LibreOffice you will have to extend the range for every newly added data set, because range with empty cells will have been cut after document has been opened with LibreOffice
Comment 5 Bugcruncher 2013-07-12 04:53:57 UTC
Created attachment 82356 [details]
Sample Document

See comment above how to use
Comment 6 Alex 2013-10-23 14:16:42 UTC
I have created a chart that the data are being added daily. I want to modify the range to extend until the next week to reduce the hassle to change the range daily. Currently to overcome this bug i use Apache open office to change the range.
Comment 7 QA Administrators 2015-04-01 14:42:31 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-04-24 16:46:21 UTC
(In reply to Bugcruncher from comment #4)
> I also observe that problem with 4.0.3 on WIN, and I agree with  David
> Wells' analysis. 
> That definitively was not a problem with LibreOffice 3.3.3 (I tried a
> portable Version).
> 
> The current behavior really is a painful if you have prepared a Spreadsheet
> for measurement values or similar, as you can see in attached sample
> document.
> 
> If you open it with AOO you will see that the data range is defined until
> Row 42, and you can add new measurement values for later times easily.
> 
> Working with LibreOffice you will have to extend the range for every newly
> added data set, because range with empty cells will have been cut after
> document has been opened with LibreOffice

In LibO, I see Data range: $Test.$A$1:$D$42
In Data series, they all end in 42.

Is this correct and bug can be closed as WFM?

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 9 QA Administrators 2016-09-20 09:33:32 UTC Comment hidden (obsolete)
Comment 10 Steffen 2016-09-20 09:50:53 UTC
This issue cannot be reproduced in my current version of libreoffice (Build ID: 5.1.5.2-6.fc24)
Comment 11 Steffen 2016-09-20 09:52:16 UTC
Sorry. Did not read request not to set to resolved fixed