Bug 64505 - : Where Kerberos is expected, build without it fails
Summary: : Where Kerberos is expected, build without it fails
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other BSD (Others)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-12 19:12 UTC by Mikhail T.
Modified: 2016-09-19 16:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail T. 2013-05-12 19:12:38 UTC
FreeBSD (likely -- other BSD systems too) are "known" to Libreoffice to include Kerberos.

In reality, the component is optional and can be disabled, when rebuilding the OS from sources.

On such a system, Libreoffice will fail to configure (something about krb5_sendauth).

As a work-around, one can pass --without-krb5 flag to configure, but this should not be necessary. If Kerberos headers/libraries can not be found, configure should go on without Kerberos functionality instead of erroring out.
Operating System: BSD
Version: 4.0.3.3 release
Comment 1 Julien Nabet 2013-05-18 06:56:57 UTC
Bjoern/Michael: one for you? (even if I can't confirm it)
Comment 2 Julien Nabet 2014-05-28 16:24:05 UTC
Mikhail T: could you give a new try with more recent LO version?
For your information, 4.3 is now in alpha and master sources correspond to the future 4.4.0 LO version.
Comment 3 QA Administrators 2015-01-10 18:05:59 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-02-11 19:43:49 UTC Comment hidden (obsolete)
Comment 5 Robinson Tryon (qubit) 2015-12-18 10:44:22 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2016-09-19 16:47:52 UTC Comment hidden (obsolete)