Bug 64595 - : When importing an Excel file named ranges duplicated across sheets corrupted
Summary: : When importing an Excel file named ranges duplicated across sheets corrupted
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Cell-Name
  Show dependency treegraph
 
Reported: 2013-05-14 16:49 UTC by Bruce Sobey
Modified: 2017-07-17 21:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel sheet that demonstrates the issue when opened in Libre (13.50 KB, application/vnd.ms-excel)
2013-05-14 16:49 UTC, Bruce Sobey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Sobey 2013-05-14 16:49:07 UTC
Created attachment 79312 [details]
Excel sheet that demonstrates the issue when opened in Libre

Problem description: When reading in an Excel file named ranges that have the same name across sheets are corrupted.  Seems as if Libre does not allow duplicate names across sheets

Steps to reproduce:
1. ....Import attached Excel sheet and see #NA on Summary
2. ....Sheets created by copying sheets with namaed ranges
3. ....

Current behavior:As described above

Expected behavior: If Named ranges duplicated they will be referenced by the sheetprefix then the name as is done in Excel. Not permitting duplicates is a major limitation on productivity as it limits duplicating sheets to set up new ones.

              
Operating System: Windows XP
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-05-15 16:31:14 UTC
Honestly not sure if this is a bug or an enhancement request so going to cc one of our resident spreadsheet masters :)

That being said:


I have been able to confirm the issue with the earliest version of bibisect:
Version 3.6.0.0.alpha1 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - can prevent high quality/professional work 
Medium 0- default seems appropriate



+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 QA Administrators 2015-03-04 02:18:33 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-03-22 11:49:24 UTC
Confirmed.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 4 tommy27 2016-04-16 07:27:51 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-05-22 13:25:20 UTC Comment hidden (obsolete)
Comment 6 m.a.riosv 2017-07-17 21:55:58 UTC
Works for me.
Version: 5.4.0.2 (x64)
Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: es-ES (es_ES); Calc: group