Bug 64653 - Headless convert-to PDF crashes on some docx files
Summary: Headless convert-to PDF crashes on some docx files
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: NeedsWindows2012Server
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-15 22:13 UTC by Scott Frost
Modified: 2015-04-01 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This fill will not convert to PDF (14.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-15 22:13 UTC, Scott Frost
Details
bad.docx (14.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-15 22:14 UTC, Scott Frost
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Frost 2013-05-15 22:13:21 UTC
Created attachment 79368 [details]
This fill will not convert to PDF

Here is my command line: "C:\Program Files (x86)\LibreOffice 4.0\program\soffice.exe" --headless --norestore --convert-to pdf %1

The attached file crashes every time.  I can reproduce this on multiple machines with the latest 4.x version.
Comment 1 Scott Frost 2013-05-15 22:14:37 UTC
Created attachment 79369 [details]
bad.docx
Comment 2 bfoman (inactive) 2013-05-16 08:56:53 UTC
Checked with:
LO 4.1.0.0.alpha1
Build ID: 67ce08e2c64a6615abc90d3a3c442f90d86fa69
Windows 7 Professional SP1 64 bit

Could not reproduce. File converted to PDF.
My command was: soffice.exe --headless --norestore --convert-to pdf bad.docx

Your command line with %1 is part of a script?
Comment 3 Scott Frost 2013-05-16 13:09:06 UTC
When I run it, it creates a ".~lock.bad.pdf#" file, then the process just hangs.

If I try it without --headless (or --invisible) and without --norestore, the next time I run it I get the "Due to an unexpected error, LibreOffice crashed" dialog.

Nothing is written to Windows Event Log and I have no option to save a log to the filesystem.

Perhaps it's because the machines are Windows Server 2012?  Is there a way to enable verbose logging?
Comment 4 bfoman (inactive) 2013-05-16 14:16:33 UTC
You can try to get a backtrace with WinDbg or procdump according to instructions in https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg. Please attach the log. Also always please write in the report as many details as possible - best to read http://wiki.documentfoundation.org/BugReport.
Comment 5 Jorendc 2013-05-19 20:46:39 UTC
I can not reproduce this using Linux Mint 15 x64 with LibreOffice 4.0.3.3 and following command:  soffice --headless --norestore --convert-to pdf bad.docx
convert /home/joren/Downloads/bad.docx -> /home/joren/Downloads/bad.pdf using writer_pdf_Export
Comment 6 Julien Nabet 2013-05-29 19:35:30 UTC
Scott: as suggested by bfoman could you try for the test with file name directly instead of %1 ?
Comment 7 Scott Frost 2013-05-29 19:42:32 UTC
I'm beginning to think it's a Windows Server 2012 issue.  I tried it on two different Windows 8 boxes and couldn't reproduce it, but it's reproducible on 3 different Windows 2012 Server boxes (2 virtual, 1 physical).
Comment 8 Julien Nabet 2013-05-29 19:45:02 UTC
Scott: if specific to one box, you should rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try.
If you still reproduce this, the best thing to do will be to retrieve a bt as bfoman suggested.
Comment 9 Scott Frost 2013-05-29 20:20:45 UTC
Windows 2012 Server.  Created C:\Temp\LibreOffice.  Disabled permission inheritance and forced folder to Everyone > full permissions.

Ran: "C:\Program Files (x86)\LibreOffice 4.0\program\soffice.exe" -env:UserInstallation=file:///C:/Temp/LibreOffice --headless --norestore --convert-to pdf bad.docx

Same crash.

It's not one BOX, it's the same OS across multiple boxes.
Comment 10 retired 2014-07-27 12:00:33 UTC
Am I crazy to suggest this is NOTOURBUG?

It works on several OS, except for one. Does LO 4.3.0.3 on Windows Server 2012 change anything for the better?

Is this bug still valid / reproducible with the latest LO release?
4.3RC3: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 11 Julien Nabet 2014-07-29 17:14:57 UTC
Scott: In addition to what Foss indicated, if you have time, you can try to retrieve a backtrace by following this link: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 12 QA Administrators 2015-02-19 04:39:36 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 13 QA Administrators 2015-04-01 14:52:13 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team