Download it now!
Bug 64686 - : Bug in Contour Editor
Summary: : Bug in Contour Editor
Status: RESOLVED DUPLICATE of bug 62965
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40 bibisected40newer
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-05-16 20:59 UTC by Frank
Modified: 2013-05-17 16:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace from the segfault (8.10 KB, text/plain)
2013-05-17 15:12 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank 2013-05-16 20:59:35 UTC
Problem description: 

Steps to reproduce:
1. Open a new empty document
2. Insert any graphic [Insert | Picture | from file]
3. Right click on Graphic; choose Wrap | Edit contour

Current behavior:
1. Using any method EXCEPT AutoContour, establish a contour.
2. At the completion of establishing the contour, Writer simply disappears.
3. When restarting Writer, the usual file recovery dialog is presented, and the empty file is restored. The (also empty) Contour Editor window is also restored.

Expected behavior:
The way it worked in 3.6, and the way it still works if the AutoContour option is selected when the Contour Editor is used.

Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Frank 2013-05-16 21:06:40 UTC
Additional Notes on Bug in Contour Editor:

I forgot to mention that the type of graphic file (e.g. jpg, png) doesn't seem to make any difference.

The system I am using this on is 64 bit Ubuntu 12.04 (LTS) with 8G of RAM.
Comment 2 Frank 2013-05-17 12:46:51 UTC
Additional Notes on Bug in Contour Editor:

I completely removed all traces of LibreOffice from my machine and did a fresh install of "Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)".

The contour edit bug continues exactly as I described in the earlier two posts.
Comment 3 Frank 2013-05-17 13:00:34 UTC
Additional Notes on Bug in Contour Editor:

Only after my current installation of Writer (Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) on 64 bit Ubuntu 12.04LTS did I stumble on bug #62030 which relates to the Pipette selection in the contour editor.

I was unable to reproduce the symptoms reported there, but suspect whoever looks at either of these might want to look at both.
Comment 4 Terrence Enger 2013-05-17 14:35:19 UTC
Thank you, Frank, for this bug report and your subsequent updates.


I see the same problem in master commit 6faa622, pulled 2013-04-19,
configured as ...

    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --without-help
    --with-extra-buildid

built and running on ubuntu-natty (11.04) 32-bit ...

    $ uname -a
    Linux cougar-natty 2.6.38-16-generic #67-Ubuntu SMP Thu Sep 6 18:00:43 UTC 2012 i686 athlon i386 GNU/Linux

    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Copyright (C) 2010 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    $ java -version
    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.5) (6b24-1.11.5-0ubuntu1~11.04.1)
    OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)


Here is what I did ...

(1) /path/to/soffice --norestore --writer.  Program displays empty
    Writer document "Untitled 1".

(2) If the program displays dialog "edit contour", then close the
    dialog.  Program gives focus to the document window "Untitled 1".

(3) Menu options Insert > Picture > "From File ...".  Program displays
    dialog "Insert Picture".

(4) Navigate to and select ~/lo_hacking/logs/20130419_1028.png, and
    click <Open>.  Program shows the image in the document window.

(5) Right-click on the the image and from the pop-up menu select Wrap
    > "Edit Countour...".  Program displays "Contour Editor" with a
    larger version of the picture overlaying a smaller one.

    (For comparison, the version of LibreOffice delivered with
    ubuntu-natty, 3.3.4, shows the picture only once in "Contour
    Editor".)

(6) In the toolbar, click <Ellipse> and move the mouse cursor over the
    picture.  Mouse cursor changes to a cross-hair.

(7) Drag the mouse cursor from one point on the picture to another.
    Program unsaturates the part of the picture outside the generated
    ellipse and then crashes with a segfault.  Backtrace coming soon.
Comment 5 Terrence Enger 2013-05-17 15:12:33 UTC
Created attachment 79469 [details]
gdb backtrace from the segfault

The segfault is at SdrUndoObjList::SdrUndoObjList,
svx/source/svdraw/svdundo.cxx line 708, which reads ...

    m_pListener = new ObjListListener(*this, *pObj, *pObjList->GetModel());

pObjList is NULL, and the segfault follows immediately.
Comment 6 Terrence Enger 2013-05-17 15:17:49 UTC
Responding to comment 3 ...

Bug 62030 is different in that it does not report a crash, neither in
the bug report nor in my test with localbuilt master.  Of course, it
may still be "related".
Comment 7 Terrence Enger 2013-05-17 16:22:58 UTC
I am marking this as a duplicate of bug 62965 "EDITING: image contour
editing crashes" because the backtraces from the crashes are as
similar as can be up to and including frame #13.

*** This bug has been marked as a duplicate of bug 62965 ***