Download it now!
Bug 64768 - layout loop on a particular docx file when loading a particular page
Summary: layout loop on a particular docx file when loading a particular page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2013-05-19 19:19 UTC by Jorendc
Modified: 2017-03-12 04:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (74.09 KB, text/plain)
2013-05-19 19:27 UTC, Jorendc
Details
bibisect log (2.94 KB, text/plain)
2013-05-27 14:34 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-05-19 19:19:30 UTC
How to reproduce:
* Download attachment 72382 [details]
* Open it using LibreOffice

While opening that file you'll see that the page number increase (bottom left). When it's on page 25, libreoffice freezes (CPU to 100%).

Not reproducible using LibreOffice 3.6.6.2. On that version it opens 28 pages without a freeze.

Kind regards,
Joren
Comment 1 Jorendc 2013-05-19 19:20:13 UTC
On IRC:
<arnaud_versini> jorendc: I confirm, this is a bug :-)
Comment 2 Jorendc 2013-05-19 19:27:51 UTC
Created attachment 79543 [details]
backtrace
Comment 4 Michael Stahl (CIB) 2013-05-28 17:01:20 UTC
was introduced by:

commit 355d25eac764713f4d52eac801ade6e2ff1deab0
Author: Cédric Bosdonnat <cedric.bosdonnat.ooo@free.fr>
Date:   Wed Sep 19 16:19:37 2012 +0200

    n#779627: added quite some compat options from the ww8 filter on writerfilter

specifically this setting:

    xSettings->setPropertyValue( "TableRowKeep", uno::makeAny( sal_True ) );


i guess we need that setting for MSO interop in general
even if it causes a loop on this particular file?
Comment 5 Björn Michaelsen 2013-06-27 10:19:22 UTC
Updating version as per Comment 4.
Comment 6 Cédric Bosdonnat 2014-01-20 08:57:14 UTC
Restricted my LibreOffice hacking area
Comment 7 Jorendc 2014-07-18 19:12:43 UTC
Still reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: eddd7646d672ea9b0561dacb09da224d098e531e
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-07-18_06:13:47
Comment 8 Björn Michaelsen 2014-10-16 14:59:03 UTC Comment hidden (obsolete)
Comment 9 Jorendc 2015-04-29 18:04:33 UTC
Can't reproduce the endless loop/freeze anymore.

Tested using Version: 5.0.0.0.alpha1+ (x64)
Build ID: 2932d2db599c09ecce3faa2d627e9ee4f251183a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-28_23:53:22
Locale: nl_BE

Marking as RESOLVES WORKSFORME.

Kind regards,
Joren
Comment 10 Robinson Tryon (qubit) 2015-12-17 04:33:49 UTC Comment hidden (obsolete)