Download it now!
Bug 64805 - FORMATTING: Table formatting error after saving file
Summary: FORMATTING: Table formatting error after saving file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-21 01:30 UTC by michael.kingsland
Modified: 2015-03-11 22:42 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
The document that was used to create the bug in it's original version before saving as MS Word doc. (25.75 KB, application/vnd.oasis.opendocument.text)
2013-05-21 01:30 UTC, michael.kingsland
Details
file after saving as MS Word doc. (26.00 KB, application/msword)
2013-05-21 01:32 UTC, michael.kingsland
Details
Screenshot of saved file after opening with MSWord (164.99 KB, image/png)
2013-05-21 02:04 UTC, michael.kingsland
Details
Screenshot of saved file after opening with libreoffice (148.99 KB, image/png)
2013-05-21 02:04 UTC, michael.kingsland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description michael.kingsland 2013-05-21 01:30:00 UTC
Created attachment 79595 [details]
The document that was used to create the bug in it's original version before saving as MS Word doc.

Problem description: 

Contents from last cell in row are moved to and appended to contents of first cell in the next row upon reopening a formerly correctly formatted file after saving as a 'Microsoft Word 2003 .doc' file. The same saved file displays correctly in MS Word.

Steps to reproduce:
1. properly configure table and fill with content
2. save file as 'Microsoft Word 2003 .doc'
3. reopen file with libreoffice

Current behavior:
shifting cell content

Expected behavior:
reopen file without any changes
              
Operating System: Mac OS X
Version: 4.0.3.3 release
Comment 1 michael.kingsland 2013-05-21 01:32:06 UTC
Created attachment 79596 [details]
file after saving as MS Word doc.
Comment 2 michael.kingsland 2013-05-21 02:04:08 UTC
Created attachment 79597 [details]
Screenshot of saved file after opening with MSWord
Comment 3 michael.kingsland 2013-05-21 02:04:58 UTC
Created attachment 79598 [details]
Screenshot of saved file after opening with libreoffice
Comment 4 ign_christian 2013-05-21 02:45:08 UTC
I can confirm same behaviour with LO 4.0.3.3 (Win7 32bit), same result as attachment 79596 [details] & attachment 79598 [details]

Don't know what is shown on MSO with that .doc file (attachment 79596 [details])?
Comment 5 Thomas van der Meulen 2013-05-26 17:27:00 UTC
Thank you for your bug report, I can't reproduce this bug running libreoffice Version: 4.1.0.0.beta1
Build ID: 3a2c2d2417101e45fe07cfd8358acf2204a98f3 on Mac osx 10.8.3 

I got the same resold that the screenshot of Ign showed.
Comment 6 Thomas van der Meulen 2013-05-26 17:30:19 UTC
sorry correction:I CAN reproduce this bug!
Comment 7 QA Administrators 2015-03-04 02:20:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 8 michael.kingsland 2015-03-11 22:42:56 UTC
Problem does not appear any longer in version 4.3.4.1 on 64 bit Windows 8.1.