Download it now!
Bug 64918 - UI EDITING Find by format doesn't show non-integer font sizes on the Find Screen
Summary: UI EDITING Find by format doesn't show non-integer font sizes on the Find Screen
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2013-05-23 14:00 UTC by elicoten
Modified: 2019-10-15 20:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot #1 showing the options (150.62 KB, image/png)
2013-05-30 13:44 UTC, elicoten
Details
Screenshot #2 showing the result (112.21 KB, image/png)
2013-05-30 13:44 UTC, elicoten
Details
screencopy of find&replace dialog in the master (165.42 KB, image/png)
2016-01-24 08:11 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elicoten 2013-05-23 14:00:00 UTC
Find by formatting doesn't return any results if a non-integer font size is returned. 

To reproduce:
1. Enter some text in font size 11pt
2. Enter some more text in font size 11.5pt
3. Open the Find & Replace dialog (CTRL+H)
4. Click More Options
5. Click Format
6. Enter 11.5pt into the Size box.
7. Click ok and then Find
8. Observe 'Search key not found' error

Trying the same but entering 11pt at step 6 works fine so the problem seems to be specific to non-integer font sizes.
Comment 1 Christopher M. Penalver 2013-05-25 12:56:55 UTC
Unreproducible due to option noted in Description not being available in:
Version: 4.2.0.0.alpha0+
Build ID: 979def88090633bfee0e0445b19999a1dac71ed
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002

Would this functionality be provided by an extension?
Comment 2 elicoten 2013-05-30 13:44:29 UTC
Created attachment 80042 [details]
Screenshot #1 showing the options

I have no extensions installed so I assume that this is part of the core functionality.

I have attached two screenshots showing the problem. Notice that in the second one underneath the find box it says 13pt when I specifically entered 13.3pt. Also I set the text to 13pt so if it really was looking for 13pt text, it would have found the second line of text in the document. As noted previous this does work correctly.
Comment 3 elicoten 2013-05-30 13:44:55 UTC
Created attachment 80043 [details]
Screenshot #2 showing the result
Comment 4 elicoten 2013-05-30 13:46:05 UTC
To clarify what I said in comment 2: "As noted previous this does work correctly." - I was referred to searching for whole integer sizes - so if it was searching for 13pt, it would have found the text.
Comment 5 elicoten 2013-05-30 13:50:13 UTC
For some reason I just tried it again and it worked.  However, the display on the find and replace screen is still wrong (i.e. I entered 13.3pt but it showed 13pt on the Find & Replace screen afterwards).

I have noticed the screenshot I've provided is wrong as I've entered the wrong value into the Format box but it at least shows where the options in question are.
Comment 6 elicoten 2013-05-30 13:53:21 UTC
After some more experimenting - the problem occurs when the size is set through styles. Find formatting only seems to find direct formatting but not formatting that is applied through styles.
Comment 7 Christopher M. Penalver 2013-06-01 18:00:14 UTC
1) lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Writer via a terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1183368/+attachment/3691990/+files/example.odt && lowriter --nologo example.odt

Ctrl+H -> click dropdown box Search for -> button More Options -> button Format... -> in the Text Format(Search) window tab Font in text box Size type 11.5 -> button OK and underneath the Search dropdown box it notes 11.5, as it does in Microsoft Office Professional Plus 2010 Word Version 14.0.6023.1000 (32-bit).

4) What happens instead is it displays 12. However, it still successfully searches and finds 11.5 so this is a cosmetic UI issue.

Also reproducible in:
Version: 4.2.0.0.alpha0+
Build ID: 979def88090633bfee0e0445b19999a1dac71ed
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002
Comment 8 A (Andy) 2015-03-07 20:19:29 UTC
For me not reproducible with LO 4.4.1.2, Win 8.1

Is this still reproducible for other users or was it maybe already resolved in the meantime?
Comment 9 Jean-Baptiste Faure 2015-03-16 05:45:37 UTC
Not reproducible for me too with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you still encounter the same issue with one of the current stable versions or with the master.

Best regards. JBF
Comment 10 Christopher M. Penalver 2016-01-24 07:11:12 UTC
Apologies for taking *so* long to get back to this. https://bugs.documentfoundation.org/show_bug.cgi?id=64918#c7 was reproducible as written exactly in:
Version: 5.0.2.2
Build ID: 1:5.0.2-0ubuntu7
Locale: en-US (en_US.UTF-8
Comment 11 Jean-Baptiste Faure 2016-01-24 08:11:00 UTC
Created attachment 122185 [details]
screencopy of find&replace dialog in the master

Confirming the viewing issue: the non-integer font sizes applied by direct formatting and searched through "More Options > Format button" are shown rounded.
Reproducing steps are described in comment #7.
The search itself works as expected.

Tested on version 4.4.7, 5.0.5.0.0+, 5.1.1.0.0+ and master.

Best regards. JBF
Comment 12 Luke Kendall 2016-04-01 06:19:15 UTC
Confirmed also while trying to workaround https://bugs.documentfoundation.org/show_bug.cgi?id=99014, in LO 5.1.1.3.

I have occasional single paragraphs, or whole pages, that are using the old (source) template's typeface (Times New Roman) but the new font size (10.5 rather than 14pt), even though the paragraphs are the new body text style ("CSP - Chapter Body Style")

I'm hesitant to try to find all occurrences of Times New Roman 14pt and change them all to Georgia, because of this bug: https://bugs.documentfoundation.org/show_bug.cgi?id=62603#add_comment

I note that Find&Replace for fractional font sizes fails.  I can see Times New Roman 10.5pt text in my document, but if I search for it using the F&R dialogue, it fails, reporting:
    Times New Roman, 11pt
    Search key not found
That statement is true, but unfortunately, F&R was supposed to be searching for 10.5pt text, as selected from the menu of available font sizes, and for which many instances could be found.  It appears that F&R may also be converting fractional font sizes to integer sizes before performing its search!

Searches for Times New Roman, 14pt, for example do work.
Comment 13 QA Administrators 2017-10-23 14:00:12 UTC Comment hidden (obsolete)
Comment 14 Jean-Baptiste Faure 2017-10-28 20:53:42 UTC
Still reproducible with current master.

Best regards. JBF
Comment 15 QA Administrators 2018-10-29 03:57:37 UTC Comment hidden (obsolete)
Comment 16 elicoten 2018-10-30 21:50:25 UTC
Still present

Version: 6.1.2.1
Build ID: 1:6.1.2~rc1-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 17 Christopher M. Penalver 2019-10-15 20:20:32 UTC
Not reproducible with:
Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Ctrl+H > Format > Size: 11.5 > OK > Find: Hello > Find Next

and the Hello with a 11.5 pt was highlighted.