Bug Hunting Session
Bug 65050 - EDITING: automatic insertion of non-breaking space before specific punctuation marks in French texts broken
Summary: EDITING: automatic insertion of non-breaking space before specific punctuatio...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:4.2.0 target:4.1.0.1
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-27 19:47 UTC by SAINT MARC
Modified: 2013-11-20 16:10 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison of punctuations (typewriter and typographical solutions) (37.30 KB, application/pdf)
2013-06-02 21:18 UTC, László Németh
Details
Minimal text in french (7.92 KB, application/vnd.oasis.opendocument.text)
2013-06-11 09:41 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SAINT MARC 2013-05-27 19:47:30 UTC
Bonjour, 
	quelques petits problèmes avec la version 4.1.0.0.beta1 :
		Pas d'espace insécable automatique avec les doubles points : ; ! comme dans la version 4.0.3.3
		problème de stabilité des commentaires qui ont tendance à s'effacer.

	en espérant que ces petits défauts pourront être corrigés dans les prochaines versions
	Cordialement
                    Jean Paul Saint Marc
Hello,
some small problems with 4.1.0.0.beta1 release:
No automatic hard space with double points:;! as in version 4.0.3.3
stability problem of the comments tend to fade.

hoping that these small defects can be corrected in the next release
Regards
              Jean Paul Saint Marc
Operating System: Mac OS X
Version: 4.1.0.0.beta1
Comment 1 Jacques Guilleron 2013-05-28 12:57:47 UTC
Hello Jean-Paul,

Reproduced with Libreoffice 4.1.0.0.beta1 and Windows 7 Home Premium.
Non breaking spaces are lacking before double ponctuation even if "Add non beaking space before specific ponctuation marks in french text" is checked in AutoCorrect > Localized Options.

Thanks for reporting,

Have a nice day,

Jacques Guilleron
Comment 2 Jean-Baptiste Faure 2013-06-01 20:21:07 UTC
Confirmed on Version: 4.1.0.0.beta1+ (Build ID: d2c26bafc7675080c9cd65ac9844ae39497bd37) under Xubuntu 12.04 x86-64.

Updated summary to use standard keywords for this issue (non-breaking, French, punctuation).

Best regards.
Comment 3 Jean-Baptiste Faure 2013-06-01 20:29:43 UTC
This regression seems to affect only Writer, it works as expected in Calc and Impress.

Best regards. JBF
Comment 4 Michael Meeks 2013-06-01 20:34:29 UTC
Laszlo - looks like this might be in your area ? :-) a MAB for 4.1 ...
Comment 5 László Németh 2013-06-02 21:12:53 UTC
Michael: Maybe this is in my area, thanks for the question. :) I will check my Graphite patch, but I believe, this problem is related to the original code of Cédric.

Cédric: I will check and try to fix the old Linux Libertine G/Linux Biolinum G problem with the inserted non-breaking space in, if possible, for 4.1.  It would be fine to find a better solution also for the non-Graphite fonts, because NBSP is a typewriter solution for French texts, not a typographical one, see the attached PDF. The correct space size before the !, ?, ;, :  is specified by French typographical literature, only ~1/6 em size, not a space.
Comment 6 László Németh 2013-06-02 21:18:47 UTC
Created attachment 80167 [details]
comparison of punctuations (typewriter and typographical solutions)

It seems, Times New Roman uses a little larger default spaces before the punctuation marks !, ?, :, ; (this better for the French typesetting). Graphite font Linux Libertine G (without automatic insertion of NBPS) uses the correct space in French and Hungarian texts.
Comment 7 László Németh 2013-06-03 06:41:44 UTC
(In reply to comment #5)
This problem is not related to Graphite. (Fix for Bug 52540 didn’t modify the behaviour of the NBSP insertion.)
Comment 8 Caolán McNamara 2013-06-11 08:53:48 UTC
I'm a little confused about this bug, is this an autocorrect bug (e.g. the kind of thing that might be fixed by http://cgit.freedesktop.org/libreoffice/core/log/?id=e2b9946022c2a286ebac625ccb45f5ddddd5a5d6) or a font rendering issue ? Can I get the minimum procedure to reproduce ?
Comment 9 László Németh 2013-06-11 09:39:25 UTC
(In reply to comment #8)
Hi Caolán. LibreOffice inserts non-breaking spaces before every exclamation and question marks, comma and semicolon in French language documents. I believe, this feature was implemented by Cédric, adding a Localized options page and an "Add non breaking space before specific punctuation marks in french [sic!] text" to the Autocorrect settings. This feature has worked in LibreOffice 4.0.3.3, yet.
Comment 10 Jacques Guilleron 2013-06-11 09:41:16 UTC
Created attachment 80671 [details]
Minimal text in french
Comment 11 László Németh 2013-06-11 09:43:50 UTC
Caolán: Sorry for my off topic comments about the possible improvement of this feature.
Comment 12 Michael Stahl (CIB) 2013-06-11 10:54:22 UTC
on current master i'm getting Autocorrect action on
"Foo:" "Foo;" "Foo!" "Foo?" but not "Foo."

in the absence of contrary information i'll claim that
the bug is fixed by:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2b9946022c2a286ebac625ccb45f5ddddd5a5d6

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1af2f810624c0e772880d5fafd27cdefa6c88d2c
Comment 13 Jacques Guilleron 2013-06-11 23:52:26 UTC
Hi all,

I confirm non-breaking spaces work again in French texts.
Verified with master-2013-06-11 LO 4.2.0.0.alpha0+ 
Build ID: c36348f20c4fcb6ae1acb0fd06c19edfa9fb108 & Windows 7 Home Premium.

Thank you very much.

Jacques Guilleron
Comment 14 Jean-Baptiste Faure 2013-06-16 14:35:08 UTC
Verified in Version: 4.1.0.0.beta2+ (Build ID: 5adfa746fb176c00cefc5fa34c79214fe166855) under Xubuntu 12.05 x86-64

Thank you very much. JBF
Comment 15 SAINT MARC 2013-06-17 15:58:15 UTC
The bug is still present even in the 4.1.0.0.beta2 release, I use LibreOffice with MacOS 10.8.4
For my work I use the Version 4.0.4.1 (Build ID: (7fdd5ee61c1c7379dd088f5d50265f0adbccf53) LibreOffice where this bug n is not present.
Thank you for correcting this problem
Jean Paul Saint Marc

Le 16 juin 2013 à 16:35, bugzilla-daemon@freedesktop.org a écrit :

> Jean-Baptiste Faure changed bug 65050 
> What	Removed	Added
> Status	RESOLVED	VERIFIED
> 
> Comment # 14 on bug 65050 from Jean-Baptiste Faure
> Verified in Version: 4.1.0.0.beta2+ (Build ID:
> 5adfa746fb176c00cefc5fa34c79214fe166855) under Xubuntu 12.05 x86-64
> 
> Thank you very much. JBF
> 
> You are receiving this mail because:
> You reported the bug.