Download it now!
Bug 65097 - EDITING: Searching sheet backward and upward improvement
Summary: EDITING: Searching sheet backward and upward improvement
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2013-05-28 21:18 UTC by Ljiljan
Modified: 2019-02-01 20:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2013-05-28 21:18:15 UTC
Improvement description: 

When searching, it is annoying to have question "LibreOffice calc has searched to the end of the sheet. Do you want to continue at the beginning?

Steps to reproduce:
1. Write in A1 "Example 1"; in A2 "Example 2"; in A3 "Example 3"
2. Go to A2 (it is currently selected)
3. Go Edit -> Find or press CTRL + F
4. Type "Example 1" and press Enter
5. Libre Office will ask you "LibreOffice calc has searched to the end of the sheet. Do you want to continue at the beginning?"

Current behavior:

Libre Office will ask you "LibreOffice calc has searched to the end of the sheet. Do you want to continue at the beginning?" and "Yes" should be pressed. This is annoying specially when you have to find for example student index number which is unique for each student and the large tables exist.


Expected behavior:

There should be option "Seach backward and upward". In student index number example, you expect Calc will search complete table, not from the current position.  
Operating System: Ubuntu
Version: 4.0.3.3 release
Comment 1 m.a.riosv 2013-05-29 22:32:36 UTC
Change importance from normal to enhancement.
Comment 2 tolfeg 2014-10-07 21:59:58 UTC
Maybe it would be OK to have an option to turn the message off, but I depend on this dialog to be sure I have found all instances. It is so critical to have the warning that I have held off installing updates because one update did not have the warning and I deemed that such a great defect that I have stopped installing updates. I depend on Calc.
I find this "suggestion" a serious defect.
Comment 3 tolfeg 2014-10-07 23:07:57 UTC
Libre Office does NOT ask you "LibreOffice calc has searched to the end of the sheet. Do you want to continue at the beginning?"

This behavior breaks an essential behavior of Search. It has been in products LibreOffice and OpenOffice were based on; Excel for decades. It is the only way Search indicates it THINKS it has completed searching for a term.

With Regular Expressions it is easy to not specify the search expression the way you think it should work. This warning saves hours of being lost in the weeds thinking a term is not in your file, when in fact you mis-specified the search argument.

It is also possible to have Regular Expressions checked and have your search argument misinterpreted by search. This check box is hidden set of check boxes.

I use LibreOffice on many different platforms and operating systems. Most haven't gone to 4.3 yet. This behavior is unacceptable under Fedora Linux, Windows XP.

This change is both a serious flaw and a death wish.
Comment 4 tolfeg 2014-10-07 23:52:42 UTC
Oddly enough, what has slowed down my response to this 'new feature' is that it is hard to phrase a search term which will connect up with this new feature. I finally just typed in the error message.

Might I point out that ANY change to dialogs like this may have serious repercussions which might be delayed many months and even years.
Gnome has changed how "pop ups" behave. They no longer float freely but are anchored. That was a bad idea because now a 'pop up' can obscure other information and cannot be moved! That means text being displayed can NEVER be seen because the pop up is locked over it!
I have been a Professional member of ACM since 1991, but have been designing and coding software since the mid 70s. I have seen almost every major software vendor, IBM, Apple, Microsoft, Oracle, Sun, Lotus, Gnome, make a similar blunder thinking they were improving things but failing to realize large parts of their user community depended on seemingly minor software behaviors.
When I see things like this, I ALWAYS get concerned that there are no responsible adults in the room . That is the major single factor in whether I concur that some piece of software is reliable enough for businesses to rely on.
Remember, spreadsheets are used to make financial decisions. I personally use it to make budgets of over $1M a year. These budgets both are very detailed and compare many years. There are a lot of blemishes I can live with. I am certain there are minor inconsistencies in almost any 25 page budget. But If I can't be sure that something is not there after I have searched for it, that software is history in a heartbeat.
W.C. Fay, wcfay@acm.org
Comment 5 Ljiljan 2014-10-08 08:10:05 UTC
My idea was to add additional feature (and not to remove existing one). When I am searching for some data in table, I don't care in which direction search is going (up or down) - I want to find the data in my spreadsheet. 

The problem with current search is that it starts in current cells and continue to the end. That dialog appear asking me to start from beginning. I wish LO team could add aditional button in LO Search toolbar (shortcut CTRL + Enter) so it search for phrase/ data in all directions. After the searching is done (in BOTH DIRECTION), dialog "searching is done" could be shown. There is really no need for asking me to start from beginning. It could be a dialog, but there are another ways of informing you. 

Secondly, speardsheets are not primarly used to make make financial decisions. It could be used in many different situation as well (such as statistical analysis of non-financial data, making lists in generals, making non-financial decisions etc...)
Comment 6 Thomas Lendo 2019-02-01 20:18:32 UTC
Closing bug as WORKSFORME as Calc doesn't ask anymore to start at the beginning anymore.

Version: 6.3.0.0.alpha0+
Build-ID: 51af3179cf972809d6495c7d58033e069f647bbf
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Gebietsschema: de-AT (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded