Download it now!
Bug 65105 - create a portable version of LibO 3.6 for format conversions
Summary: create a portable version of LibO 3.6 for format conversions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-29 00:56 UTC by bugquestcontri
Modified: 2013-11-24 11:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-05-29 00:56:58 UTC
Problem description: 

According to my understanding, LibO 4.0 has lost the feature ot open certain older file formats (which I can understand). Thus, when someone starts running versions >=4.0 the ability to open older file formats is lost. This is most likely not a problem for young people because they never used these formats. However, people a "bit" above 25 years of age, can have older file formats and start using LibO only after 3.6 is not official released any more. Thus, the older formats are lost. 

A portable version of 3.6 would be a great opportunity to always keep a 3.6 version for the need to open and older file format, convert to LibO default format and work on such an old file with LibO versions >=4.0.

IMHO this would be a great feature because to the best of my knowledge MS doesn't support certain older file formats anymore.

Solution:
Create a portable version of 3.6 (maybe with 3.6.7) and keep the portable version always for downloads beyond the official life time of 3.6. It should also be marked as "not supported anymore - only for the purpose to convert older file formats to ODF format etc)

Alternative solution:
Should it be easier, create a portable file converter for older formats to ODF.
Operating System: All
Version: 3.6.6.2 release
Comment 1 Pedro 2013-05-29 13:41:26 UTC
There are Portable versions of LibreOffice both from PortableApps.com as well as from winPortablePacks.com
See this topic
http://nabble.documentfoundation.org/Portable-vs-Parallel-which-one-is-better-td4056781.html

Maybe this information and links should be added to
http://www.libreoffice.org/download/4-0-new-features-and-fixes/
under Feature Removal / Deprecation???
Comment 2 bugquestcontri 2013-05-30 04:17:34 UTC
@Pedro - thanks for your comment and links. I was a bit shocked to see that on XP I can only install 1 version. This makes portable versions even more important to check regressions.

I recently found a nasty in bug in 4.0.3.3 portable, which does not exist in 3.6.6.2. Thus I have now the headache to decide to move to 3.6.7 or 4.0.4. With a portable version of 3.6.7 I would go straight to 4.0.4, and the portable 3.6.7 would be my workaround for the bug in 4.0.3

Now I do hope even more that we get at least 3.6.7 as a portable version.
Comment 3 tommy27 2013-09-11 19:52:56 UTC
take a look at this link: http://sourceforge.net/projects/winpenpack/files/X-LibreOffice/releases/

you will find all the portable X-LibreOffice versions from 3.3.4 to 4.1.1 including 3.6.7

setting status as RESOLVED WORKSFORME
Comment 4 bugquestcontri 2013-11-24 11:26:07 UTC
Thanks for lot for this very valuable comment. I saved 3.6.7 for the future.