Bug 65128 - checking for update takes into account Windows OS version
Summary: checking for update takes into account Windows OS version
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Installer
  Show dependency treegraph
 
Reported: 2013-05-29 13:48 UTC by Pedro
Modified: 2018-12-30 00:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2013-05-29 13:48:52 UTC
Following on the topic
http://nabble.documentfoundation.org/LibreOffice-and-Windows-2000-tp4057523.html

it would be nice if the Check Updates feature would check for the OS (at least Windows) version and suggest updates (or indicate that no further updates are available) accordingly

This would prevent from suggesting versions that will not run under the user's OS

Currently this applies to Windows 2000 (under which MSVC 2010 is not supported) but in the near future it will apply to Windows XP (which will be unsupported a year from now and under which MSVC 2012 is not supported)
Comment 1 V Stuart Foote 2013-05-29 16:02:42 UTC
Adjusting title and setting importance as high enhancement for Windows installer

However, this might need to be handled more generally to include all the OS's, and possibly offering differing "upgrade" action depending on specific Linux distribution.