Bug Hunting Session
Bug 65346 - Search bar shouldn't remain open across sessions
Summary: Search bar shouldn't remain open across sessions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 65345 (view as bug list)
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2013-06-04 12:03 UTC by Stefan Knorr (astron)
Modified: 2019-10-03 12:08 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2013-06-04 12:03:26 UTC
Try this:
1. Open a (text, spreadsheet, ...) document in LibreOffice.
2. Open the search bar via Ctrl-F.
3. Close the document.
4. Open another (or the same) document.

Observe that the search bar is still open, even though, one (i.e., I) would assume that the search bar is a session-/document-specific piece of UI. In a newly-created document, the search bar looks especially out of place.
Comment 1 Stefan Knorr (astron) 2013-06-04 12:05:42 UTC
*** Bug 65345 has been marked as a duplicate of this bug. ***
Comment 2 Jorendc 2013-06-07 15:15:03 UTC
Hi Stefan,

Thanks for reporting. I can reproduce this behavior using Linux Mint 15 x64 with LibreOffice 4.0.3.3. I'm quite sure this is already reported before, but I can't find it back anymore. Maybe somewhere mentioned in another report :-). Lets mark this one as NEW then.

Kind regards,
Joren
Comment 3 Susobhan Ghosh 2016-03-24 10:20:22 UTC
The implementation of hiding the find bar can be found here:

http://opengrok.libreoffice.org/xref/core/svx/source/tbxctrls/tbunosearchcontrollers.cxx#227
Comment 4 Thomas Lendo 2019-09-24 20:21:10 UTC
What's with find toolbars that are positioned by the user to be persistent as a default toolbar like Standard or Formatting? These users should be surprised by deactivating the find toolbar at every application start.
Comment 5 Heiko Tietze 2019-09-25 05:56:12 UTC
Stuart, would you agree to close this as WFM? Feels to me like an evergreen to talk about toolbars on or off ;-).
Comment 6 V Stuart Foote 2019-09-25 12:42:42 UTC
Yes, I think that the Find bar <Ctrl>+F should be handled like all other toolbars. If we implement a control to close all toolbars, or a control to suppress all context sensitive launches of toolbars, the Find bar should be handled the same way--meaning it should be stateful, and if implicitly left open when closing a module it should be in that same state on reopening.

I think the behavior now is correct. Agree => WFM with status quo, with potential for changes to toolbar class objects.
Comment 7 Cor Nouws 2019-10-03 12:08:24 UTC
(In reply to V Stuart Foote from comment #6)
> I think the behavior now is correct. Agree => WFM with status quo, with
> potential for changes to toolbar class objects.
+1