Bug Hunting Session
Bug 65485 - Tabs names and window titles in Character, Paragraph, B&N, Title Page dialogs are now in English
Summary: Tabs names and window titles in Character, Paragraph, B&N, Title Page dialogs...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:4.2.0 target:4.1.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-06 22:31 UTC by Martin Srebotnjak
Modified: 2013-06-12 07:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2013-06-06 22:31:16 UTC
Even though these were long localized, since they were transformed to GTK, the window title and tab names of Character and Paragraph dialogs are now in English and nonlocalizable (in 41b2). Same goes with the Bullets & Numbering dialog.

Besides, the Character tab Hyperlink has all labels/buttons in English, as well as tabs Outline & Numbering in the Paragraph dialog.

Besides, the Page dialog has tab names localized, but tabs Columns and Footnote have all strings in English ...

The Title page dialog is fully English. Also the Columns dialog, selectable in LO Writer from the Format menu.

This is a nightmare to a localizers eyes, to a localizer who keeps his work at 100 % all the time. No excuse for this.
Comment 1 Martin Srebotnjak 2013-06-06 22:37:30 UTC
Same goes for the:
- Statistics and Security tabs of the Properties dialog (File - Properties)
- Versions dialog (File - Versions)
- AutoText dialog (Edit - AutoText)
- Insert Section dialog (Insert - Section)

etc.

Since Slovenian had 100 % translated UI on the day of June 2, 2013 does this mean that in the last day before the beta2 checkout hundreds of strings were moved to GTK?
Comment 2 Jorendc 2013-06-08 08:48:39 UTC
Oh dangit, I think I made a translation error myself :-). "Slovak""Slovenian".

I'm sorry about that, but still I'll mark this bug as dupe of Bug 65483, due the fact they have the same 'root cause'.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 65483 ***
Comment 3 Martin Srebotnjak 2013-06-08 08:53:20 UTC
Let's reopen this, for the same reasons as with 65483.
Comment 4 Andras Timar 2013-06-11 08:35:38 UTC
share\config\soffice.cfg\modules\swriter\ui\res is missing (both on Windows and Linux). Translations would be there.
@dtardon: do you have an idea?
Comment 5 David Tardon 2013-06-12 05:33:48 UTC
a missing line...
Comment 6 Commit Notification 2013-06-12 05:37:37 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=638ecac30d04a0f13e55f2566a9e318b9dbf02f0

fdo#65485 install .ui translations for writer again



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-06-12 05:46:17 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d72d5b74c7c39aa16b808220e1a5adc26282db53&h=libreoffice-4-1

fdo#65485 install .ui translations for writer again


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-06-12 07:13:35 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dc207645d8084bb381ba875508620947dbb22b4&h=libreoffice-4-1

fdo#65485 also put the files into langpack module


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-06-12 07:13:53 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2032586fee5be10038e52123c0332b21d0de1aa4

fdo#65485 also put the files into langpack module



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.