Download it now!
Bug 65542 - FILESAVE: Writer loses drawings when saving in Microsoft Word 6 format.
Summary: FILESAVE: Writer loses drawings when saving in Microsoft Word 6 format.
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-08 15:39 UTC by RJ
Modified: 2015-04-13 17:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RJ 2013-06-08 15:39:01 UTC
Problem description: When a text document with simple drawings in it is saved in Microsoft Word 6 format the drawings are lost when the document is re-opened.

Steps to reproduce:
1. ....Open Libreoffice writer and type in a short sentence.

2. ....Use the drawing tools to add a simple rectangle to the document.

3. ....Save the document in Word 6 format (docx).

4. ....Close Libreoffice.

5. ....Open the document again in Libreoffice. The rectangle is gone.

Current behavior: the drawing of the rectangle is missing.

Expected behavior: the drawing of the rectangle should be in the document.

It seems not to matter if the drawing is anchored to the page, to the paragraph (the default), or to the character; it still goes missing.

              
Operating System: Ubuntu
Version: 3.5.7.2 release
Comment 1 Joel Madero 2013-06-09 17:49:04 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Major - loss of data
High - default seems appropriate


note: Could be a duplicate but couldn't track it down

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 QA Administrators 2015-03-16 23:56:30 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 3 Jean-Baptiste Faure 2015-03-28 16:49:19 UTC
Word 6 format (the version before Word 97) is not proposed as export format anymore. So closing as WontFix.

Note: you mentioned "docx", no problem if I follow your step to reproduce and save in this format.

Best regards. JBF
Comment 4 RJ 2015-04-13 17:11:33 UTC
I tested the bug using LibreOffice version 4.2 on Ubuntu linux. There is no longer an option to save in Microsoft Word 6 format. The only other .docx format appears to be Word 2017/2010/2013 XML and that seems to work properly. If I save a document in that format then there is no data loss.