Bug 65716 - %MACROLANG shown in dialog
Summary: %MACROLANG shown in dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-13 15:03 UTC by Leif Lodahl
Modified: 2013-06-26 08:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2013-06-13 15:03:20 UTC
In the dialogs using the variable %MACROLANG (e.g., Tools - Macros - Organize macros - Python... the variable name is shown in the dialog title (%MACROLANG macros).

Problem with English and Danish languages. I only tried on Linux: Version: 4.1.0.0.beta2+
Build ID: 5ae6803a21f5e2b6e107ee405e9b3346105c646
TinderBox: Linux-x86@34-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-12_14:35:06

It seems to correspond with Pootle file: cui/uiconfig/ui.po and context: scriptorganizer.ui ScriptOrganizerDialog title string.text


Cheers,
Leif
Comment 1 Thomas van der Meulen 2013-06-13 15:13:09 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6 on Mac osx 10.8.3. 

In version 4.0.3.3 it was Python Macros.


http://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/scriptorganizer.ui#7
Comment 2 Leif Lodahl 2013-06-20 06:13:32 UTC
Seems to be fixed in RC1.
Closing.
Comment 3 Leif Lodahl 2013-06-22 15:26:22 UTC
Still a problem. Sorry.
Comment 4 Commit Notification 2013-06-25 19:39:37 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a85aed77e68f703db04e9f78625734c7551a9281

Resolves: fdo#65716 MACROLANG not substituted in title



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2013-06-25 19:44:19 UTC
fixed in master, proposed for 4-1 in gerrit
Comment 6 Commit Notification 2013-06-25 19:59:58 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=321447137f94c986da56dc048e40c8ce46123ac4&h=libreoffice-4-1

Resolves: fdo#65716 MACROLANG not substituted in title


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-06-25 20:00:16 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9102d2517007db3afa867a9902ca526153439eb5

Related: fdo#65716 title substitutions



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-06-26 08:12:01 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3fa16f560180c4d6c2a6505bc7f348d1f99972d&h=libreoffice-4-1

Related: fdo#65716 title substitutions


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.