Bug 65736 - Libre Office hangs on using document converter
Summary: Libre Office hangs on using document converter
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-13 22:39 UTC by LooseSpokes
Modified: 2016-09-19 16:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LooseSpokes 2013-06-13 22:39:49 UTC
On attempting to convert documents Libre office hangs. First an error comes up 'soffice bin file system error' or something similiar, and then the libre office macro window comes up which won't close as 'basic' is still running.

Meanwhile the main document converter window doesn't appear to be doing anything.

Using Linux Mint 14 KDE.
Comment 1 Julien Nabet 2013-07-02 21:47:58 UTC
nickmdowson: could you give a try to a newer LO version, 3.6.6 or better 4.0.4?
Comment 2 LooseSpokes 2013-07-19 22:22:10 UTC
Hi Julien,

I couldn't and unpacked  to 3.6.6 or higher from the Linux mint repositories, so I downloaded a4.0.4.2 from libreoffice and tried this - however, when I went through the wizard to try and said "sorry, Filesystem error".

I'm not sure if this (new) problem is because of installing the program inthis slightly unusual way.

I need to upgrade my distro anyway, I'm probably going to try debian at that point over the next couple days and can see whether I can make it work with a more recent libre office version then.
Comment 3 Julien Nabet 2013-07-20 22:38:26 UTC
Ok Nick, we'll wait for your feedback after upgrading.
Comment 4 LooseSpokes 2013-07-21 18:15:26 UTC
Hi Julien,
Switched to debian (stable, KDE desktop) and I can report the same problem (file system error. when I then try to do something else in libre office (opened another window/instance) then the basic window comes; in filesmodul tab. I can send you the text of that view if it helps. another error message at this point:
BASIC runtime error
an exception occured
Type: com.sun.star.task.ErrorCodeIOException
message: .

This is now libreoffice 3.5.4.2 ; I haven't been able to try 3.6.6.6 or above on debian as to do this I would need to figure out how to install a testing package from one program on stable. However, given that I've been getting the same error consistently (including on 4.0.4.2 on Linux Mint 14 KDE) it seems that I'm experiencing a pretty consistent bug.
Comment 5 Julien Nabet 2013-07-21 19:40:44 UTC
About convertion process, what's the type of the partition where the files to convert are? Also what's the type of the partition where the converted files?

(About Debian, I use testing. Debian stable is above all for servers, do you use your machine as a server?)
Comment 6 LooseSpokes 2013-07-21 22:55:03 UTC
Hey, no it's not a server - I was wondering about using testing instead but not sure, do you find much breaks? I guess I'm also a bit apprehensive about the upgrade process (having to close down the gui before doing it..)

I'm converting from my home folder (including subdirectories) to my home folder. Previously they were just on an ext. 4 partition which was solely for /home . Now they're on a separate home partition within the encrypted LVM container (which spans the whole hard drive, excepting the boot partition.
Comment 7 Julien Nabet 2013-07-22 07:36:16 UTC
nickmdowson: i've been using it since several years and breaks are quite rare with testing (don't forget there's sid/unstable before). Now i don't use a lot of things, I suppose it depends on your use.

About partition, I just wonder if the encrypted may be the root cause.
- could you give more precision about encryption (which type for example)?
- for the test, could you create some directories on your boot partition with appropriate 777 rights and put your files to convert + destination files  there (each kind in a separate subdirectory of course)?
Comment 8 LooseSpokes 2013-08-28 16:33:48 UTC
I'm using LVM encryption across the whole drive now, with partitions within that - the default debian encryption - I have to type in my password at boot (well, immediatielly after GRUB). Note that I was getting the same problem on my previous install which had no encryption whatsoever?

I tried as you suggested and had the same problem (basic window came up etc. though I don't think it said file system error.
Comment 9 Julien Nabet 2013-08-28 18:34:49 UTC
thank you Nick for your feedback.
I put it back to unconfirmed since I don't have more questions.
Comment 10 retired 2014-07-27 12:07:52 UTC
Few things:

Is this bug still valid / reproducible with the latest LO release?
4.3RC3: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

If this persists, please provide 1) a test file to convert 2) exact repro steps on how to reproduce this issue and 3) screenshot of error message.

"I think the error was" ... is much to general to do anything productive about this, also cannot really test.

Setting to NEEDINFO until more detail is provided.
Comment 11 Julien Nabet 2014-07-29 17:18:50 UTC
In addition to what Foss indicated, you can try to retrieve a backtrace by following this link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Perhaps there won't be any but who knows...
Comment 12 QA Administrators 2015-02-19 04:39:22 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2015-04-01 14:52:12 UTC Comment hidden (obsolete)
Comment 14 Robinson Tryon (qubit) 2015-12-18 10:24:07 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2016-09-19 16:47:52 UTC Comment hidden (obsolete)