Bug 65892 - Tatar Language is missing from the default document language list
Summary: Tatar Language is missing from the default document language list
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: User-Locale
  Show dependency treegraph
 
Reported: 2013-06-18 10:49 UTC by Emir Sarı (away)
Modified: 2019-03-19 10:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (197.37 KB, image/png)
2013-06-18 10:49 UTC, Emir Sarı (away)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2013-06-18 10:49:15 UTC
Created attachment 80995 [details]
Screenshot

Tatar language was present in the language list in Preferences - Languages section, but I cannot see it anymore. 

This is rather important because it is impossible to do spell-checking on Tatar, and highly inconvenient.
Comment 1 Thomas van der Meulen 2013-06-18 15:09:19 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6 on Mac osx 10.8.4.
Comment 2 Julien Nabet 2013-06-30 20:57:37 UTC
Comment on attachment 80995 [details]
Screenshot

Mimetype fixed
Comment 3 Eike Rathke 2013-10-09 09:48:14 UTC
The screenshot shows the list of default document languages. Tatar was never present there as we don't have a locale data set for Tatar [tt-RU] and fully supported default languages need locale data assigned. You'll find Tatar in the language list of character attribution though, for example in Writer menu Format->Character, which makes it available for spell-checking if a corresponding dictionary is installed.

For how to submit locale data please see https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data
Comment 4 Eike Rathke 2019-03-19 10:58:11 UTC
Meanwhile tt-RU locale data was added in 2014 ...