Download it now!
Bug 65941 - FILE SAVE/FILE OPEN: Renaming userdefine styles not retained after saving / reopening the document
Summary: FILE SAVE/FILE OPEN: Renaming userdefine styles not retained after saving / r...
Status: RESOLVED DUPLICATE of bug 46804
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-19 17:11 UTC by aw-libreoffice
Modified: 2015-04-22 14:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File with a style I can not rename. (8.72 KB, application/vnd.oasis.opendocument.graphics)
2013-06-19 17:11 UTC, aw-libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aw-libreoffice 2013-06-19 17:11:31 UTC
Created attachment 81078 [details]
File with a style I can not rename.

Problem description: 
Renaming a userdefined style does not work.

Steps to reproduce:
1. Create a document.
2. Draw a line.
3. Create a style "UserDefinedStyle" based on the style assigned by default to the line.
4. Change some properties.
5. Assing this new style to the line
6. Rename it - e.g. to "UserDefinedStype3"
=> Works
7. Save an close the file.
8. Reload the file
9. Rename the style to "UserDefinedStyle4"
10. Save, close and reload
=> Still the old style name.

Current behavior:
=> Style rename does not work once the file with the style has been saved.
Expected behavior:
=> rename should work.
              
Operating System: All
Version: 4.0.3.3 release
Comment 1 Cor Nouws 2013-06-19 21:02:00 UTC
Hi aw,
thanks for reporting.
Did you mention "template" for some special reason in the summary?

Curently I test in 404 (LOL 4.0.4 ;) ) - should be checked when the problem was introduced.
Best - Cor
Comment 2 aw-libreoffice 2013-06-20 08:01:00 UTC
(In reply to comment #1)
> Hi aw,
> Did you mention "template" for some special reason in the summary?
No - I run a german version - I do not know what is the right translation and use style/tempalate.
Comment 3 Michael Stahl (CIB) 2013-10-08 22:26:05 UTC
apparently last working version was ... wait a minute, this
is broken in every version back to OOo 3.0.1, why was this
tagged "regression"?
Comment 4 Cor Nouws 2013-10-09 07:56:55 UTC
Hi Michael,

(In reply to comment #3)

> why was this tagged "regression"?

Could be that I made a mistake. (Possibly because I have the idea that I use it now and then with success ;) )
Appologies,
Cor
Comment 5 QA Administrators 2015-04-01 14:40:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 6 Buovjaga 2015-04-22 14:23:36 UTC
Reproduced, but this is a dupe.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI

*** This bug has been marked as a duplicate of bug 46804 ***