Download it now!
Bug 66020 - FORMATTING: Suggestion - add "use typography golden ratio" option when in Paragraph option
Summary: FORMATTING: Suggestion - add "use typography golden ratio" option when in Par...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 18:46 UTC by Veselin
Modified: 2015-08-01 15:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Veselin 2013-06-21 18:46:45 UTC
No problem. A suggestion.

Typography options for some fonts.

LO comes with many fonts. Unfortunately without setting the paragraph options right, many of the fonts look way to dense/loose which makes them appear bad.

If LO has the option to apply the so called golden ratio, then a lot of users will be able to use most fonts very well.

http://www.pearsonified.com/2011/12/golden-ratio-typography.php

Here is an explanation of what is it and why is so good. Basically, fonts have different parameters and require different spacing, based on their design, to look well. Otherwise many good fonts may be not good for the eyes of the reader, without him being able to explain why.

There is formula (in the post) which can be used to calculate those spaces automatically, so a user should not be hardcore typography designer to use this.

Some web sites, wordpress themes and CMS use this already. If it is possible to install that in LO it will be very attractive for a lot of newbies (like myself).
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 Joel Madero 2014-06-25 03:57:18 UTC
@Michael - I wanted your opinion on this one as it seems like it would help writer the most (long dense paragraphs most common here). 

Any thoughts? Thanks in advance

@Khaled - I see you cc'ed yourself on it ;) Any opinions from you also much appreciated :-D
Comment 2 Owen Genat (retired) 2015-01-25 01:19:39 UTC
(In reply to Veselin from comment #0)
> LO comes with many fonts. Unfortunately without setting the paragraph
> options right, many of the fonts look way to dense/loose which makes them
> appear bad.

LO v4.4 ships with 87 TTF font files in about 19 different fonts. Setting font leading (line height) is generally (for best effect) done on a per-font basis.

> If LO has the option to apply the so called golden ratio, then a lot of
> users will be able to use most fonts very well.
> 
> http://www.pearsonified.com/2011/12/golden-ratio-typography.php

The idea of using the golden section (1.618...) as a ratio to determine leading based on font size, seems somewhat unique to the cited blog post e.g., Bringhurst makes a general recommendation of a ratio of 1.3-1.5 that of the font size, but qualifies this by indicating that certain fonts require more or less leading. There is no magical number suited to all fonts. I generally use 1.333 for ease of calculation (i.e., 12/16 pt). I also find that ratios of 1.6+ begin to make the lines of most text fonts (Times, Liberation, Libertine, Gentium, Minion Pro, etc.) separate on-screen to the point that paragraphs become indistinct (and thus require blank line separation). In general the quoted figures in the article seem specific to fairly status-quo (e.g., WordPress) web-based publishing, which often uses larger leading with blank lines between paragraphs, rather than solid-set paragraphs with first line indentation. This further highlights how different publication media use different metrics / methods and that there is no general solution to these sorts of issues in typography.
 
> There is formula (in the post) which can be used to calculate those spaces
> automatically, so a user should not be hardcore typography designer to use
> this.

Presumably this is a reference to the graph showing adjustment of leading based not only on font size, but also line length. I would think that setting leading automatically based on page / column / frame metrics would be beyond the scope of what LO is seeking to offer. Office software is not desktop publishing software.
 
> Some web sites, wordpress themes and CMS use this already. If it is possible
> to install that in LO it will be very attractive for a lot of newbies (like
> myself).

For the reasons already indicated, web-typography is not the same as print-typography. There is no standard for leading / line length / paragraph indication suited to all fonts or all publication methods. Not a reasonable enhancement request IMO.
Comment 3 João Paulo 2015-06-08 08:08:11 UTC
It's a good idea, but unfortunately it doesn't work on each font:

I used Adobe Caslon Pro font, but its line height was higher in relation to other fonts: I had to actually lower the line spacing to less than 100% (90% if I recall right) so it wouldn't seem odd compared to the sans serif font I used as companion on my documents.

Sorry, @Veselin, your idea is good, but is unpractical. I am marking it as a "lowest" enhancement, and leave this bug as unconfirmed until someone marks it as new. Maybe when one developer get this bug to solve, s/he will:

* add this option with a warning that not all fonts will work well;
* add a link to the help interface so people can learn about the golden interface and do the adjustments needed.

PS: @Owen, IMO I disagree there are two kinds of typography (printed and web). They both use the same sets of rules, just the sizes of the fonts are adjusted to cause less strain on the eyes: Paper has more resolution and can use fonts on lower point sizes (besides it emits no light); e-paper also emits no light, but has less resolution; computer screens may have high resolutions or not, but they emit light and the web designer has to use bigger fonts so not to strain the readers' eyes. But the golden rule can be applied the same way on all media (or almost: if the result is, i.e., 25.8px, using 26px won't hurt).
Comment 4 Jean-Baptiste Faure 2015-08-01 15:18:56 UTC
I trust comment #3 and reporter seems not to be very interested in arguing in favour his proposition. Closing as WontFix.

Please, feel free to reopen if you have clear argumentation in favour of this change and showing that it is really an enhancement. Not only some obscure belief in the virtue of gold number.

Best regards. JBF