Download it now!
Bug 66138 - Set text anchor in style; shape doesn't use it
Summary: Set text anchor in style; shape doesn't use it
Status: RESOLVED DUPLICATE of bug 46798
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2013-06-24 23:16 UTC by alyxyla
Modified: 2019-10-09 16:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alyxyla 2013-06-24 23:16:21 UTC
Shapes don't seem to be honoring the style's "Text anchor". 

Create a default rectangle and add some text.  It is aligned with the center of the shape.  If you right click on the rectangle and choose "Edit Style", the text anchor is at the top center.  If you right click on the rectangle and choose "Text..", the text anchor is in the center of the shape.  Changing the (Default) style's text anchor has no affect on this shape, or future shapes created with this style.  This is reproducible with Default style and custom styles.
Comment 1 Buovjaga 2014-11-07 13:46:46 UTC
Reproduced.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 8b21b5cbe78945b27525b4ce78ae3d981f90590f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-06_03:55:51
Comment 2 Buovjaga 2015-01-07 18:26:28 UTC
Lowered version number after reproducing with:

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 QA Administrators 2016-01-17 20:03:01 UTC Comment hidden (obsolete)
Comment 4 eisa01 2017-10-20 20:57:08 UTC
Still present. Also present in 3.3.0 as per comment 3, so this is inherited

This was reproduced on Windows as well as per comment 2, so setting OS to all.

Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 QA Administrators 2018-10-21 02:51:00 UTC Comment hidden (obsolete)
Comment 6 eisa01 2018-12-08 08:29:40 UTC
Still present

Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-12-06_23:52:29
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Regina Henschel 2019-10-09 16:07:06 UTC
I think it is duplicate to bug 46798. And the error still exists in Version: 6.4.0.0.alpha0+ (x64)
Build ID: b2d8093b19642038631dfb8f1ab6745a380a652c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-23_22:42:37
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 46798 ***