Bug 66513 - can't understand excel file (it look in chinese characters)
Summary: can't understand excel file (it look in chinese characters)
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4 all versions
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-02 16:48 UTC by mcjarod
Modified: 2013-07-15 11:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The xls file generate by my software Paradox (zip) (914.49 KB, application/zip)
2013-07-02 16:48 UTC, mcjarod
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mcjarod 2013-07-02 16:48:18 UTC
Created attachment 81895 [details]
The xls file generate by my software Paradox (zip)

I generate a xls file with a software call "Paradox", it open with ms office without any problem, but in LibreOffice it looks with chinese characters, the file is confidential, but I attach here, thanks for the answer.
Comment 1 Jorendc 2013-07-02 17:19:40 UTC
*** Bug 66512 has been marked as a duplicate of this bug. ***
Comment 2 Julien Nabet 2013-07-02 19:58:07 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.
Here are some console logs:
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:oox.storage:16268:1:oox/source/helper/zipstorage.cxx:70: ZipStorage::ZipStorage exception opening input storage: 
warn:legacy.osl:16268:1:sc/source/ui/docshell/impex.cxx:624: lcl_appendLineData: data overflow
warn:vcl:16268:1:vcl/generic/fontmanager/fontconfig.cxx:892: In glyph fallback throwing away the language property of fr because the detected script for '0xb01' is Oriya and that language doesn't make sense. Autodetecting instead.
Comment 3 Petr Mladek 2013-07-12 13:14:25 UTC
I am able to open the file with LO 3.4. It fails with all newer versions.

It seems that there is some problem with the type detection because some version tries to open the file as using the CSV filter and some as a normal ASCII text.

I do not see the warnings on the console log. I wonder if they are produced by a debug build or so.
They mean some problems with uncompressing and might be related to the wrong type detection.

We need to fix the bug because it blocks the user. On the other hand, it is pretty old and nobody reported it yet, so it must be a kind of corner case. The "Paradox" software probably generates a bit non-standard documents => it should not block the next bugfix release with many other fixes and improvements => lowering the severity a bit
Comment 4 Eike Rathke 2013-07-15 10:59:15 UTC
I can't even open the file in Excel 2010, idles for a while with "opening MS-Office" and when cancelling that says "The file is corrupt and cannot be opened."