Bug Hunting Session
Bug 66540 - LibreOffice slows Outlook and vice versa
Summary: LibreOffice slows Outlook and vice versa
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 07:44 UTC by Winfried Donkers
Modified: 2015-02-13 10:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
logfile of processmonitor (57.99 KB, text/csv)
2014-11-04 10:29 UTC, Winfried Donkers (retired)
Details
logfile(2) of processmonitor (24.81 KB, text/csv)
2014-11-06 12:49 UTC, Winfried Donkers (retired)
Details
logfile(3) of processmonitot (182.14 KB, application/zip)
2014-11-12 12:46 UTC, Winfried Donkers (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2013-07-03 07:44:35 UTC
Situation: open Libreoffice document(s) and Outlook open.

1: when editing Outlook message (no attachments):
afer copy&paste, Outlook becomes very slow at times (e.g. cursor movement may take more than 10 seconds).

2: when editing Libreoffice document (not linked with Outlook):
LibreOffice becomes very slow, i.e. one types faster than LibreOffice can handle when entering text.

LibreOffice versions 3.6 and 4.0 (probably earlier as well)
Outlook 2007
Windows XP, Windows 7

case 1 can be reproduced on many machines, case 2 is not so common (so far one user reporting problem, but very consistently).

case 2: closing Outlook makes it worse; see bug 66539
Comment 1 Winfried Donkers 2013-07-03 07:55:05 UTC
correction: Outlook 2010
Comment 2 Winfried Donkers (retired) 2013-07-11 10:21:12 UTC
Addition:
Slowness of Outlook also occurs when only the LibreOffice quickstarter is active and no documents are opened (neither the LibreOffice main screen is open).

Slowness does not occur once the quickstarter is closed.
Comment 3 Winfried Donkers (retired) 2014-04-01 10:42:53 UTC
Case 2 in comment #1 bothers now several users.

Currently we use :
LibreOffice version 4.1.5 and 4.2.2/4.2.3
MS Outlook 2010
Windows 7 professional, both 32- and 64 bit
Comment 4 Michael Meeks 2014-04-01 10:48:23 UTC
"Slowness of Outlook also occurs when only the LibreOffice quickstarter is active"

Wow - what an interesting bug. Perhaps worth poking at some output from sysinterals (Microsoft's tracing package) - particularly the process explorer - to see what craziness is going on on the system ...
Comment 5 Winfried Donkers (retired) 2014-04-01 11:01:00 UTC
(In reply to comment #4)
> "Slowness of Outlook also occurs when only the LibreOffice quickstarter is
> active"
> 
> Wow - what an interesting bug. Perhaps worth poking at some output from
> sysinterals (Microsoft's tracing package) - particularly the process
> explorer - to see what craziness is going on on the system ...

Could you give me some more clues on how to get that output?
Comment 6 Winfried Donkers (retired) 2014-04-01 11:41:23 UTC
(In reply to comment #5)
> > Wow - what an interesting bug. Perhaps worth poking at some output from
> > sysinterals (Microsoft's tracing package) - particularly the process
> > explorer - to see what craziness is going on on the system ...
> 
> Could you give me some more clues on how to get that output?

Let me be a bit more specific:
I downloaded and ran Process Explorer from MS sysinternal suite.
With 2 calc and 1 writer document open (and Outlook),
I started a new email message, filled it with 5 lines (line 1, line 2, etc.)
I moved the caret up to line 3, selected lines 3 and 4 and did Ctrl-X, followed by down-key on keyboard.
The CPU-usage for the Outlook process jumped from 0.2 to 20-25% for some seconds and the caret only moved down after some seconds.

Repeating same sort of action gave similar results.
Repeating with LO documents closed and LO quickstarter loaded gave almost similar results (CPU percentage went to 18%).
Repeating with LO quickstarter closed gave CPU percentage below 1%.

I bet this is not the output you want, so please disclose me your wishes ;-)
Comment 7 QA Administrators 2014-11-02 16:46:43 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 8 Winfried Donkers (retired) 2014-11-03 07:03:57 UTC
Problem still present in version 4.3.3.2.

@MMeeks: Could you expand on your suggestion to use the process explorer?
Comment 9 Michael Meeks 2014-11-03 12:02:29 UTC
So - really no idea what's going on; I believe sysinternals has a file monitor app - if the problem goes via files we can use that to get a handle on what is going on there (perhaps).

Beyond that - you could attach windbg and try to reproduce the problem, and break inside LibreOffice when its consuming time and get a stack trace or two.

I assume that we see a chunk of CPU time coming from a soffice.bin process while the hanging is going on ? [ or is it all inside outlook? ].

Hard to know where to go here really short of replicating the setup.
Comment 10 Winfried Donkers (retired) 2014-11-04 08:28:11 UTC
I can reproduce the behaviour on all machines in our company, but process explorer and proces monitor from sysinternals just show an increase in CPU-% for Outlook (see comment #6, on some machines it rises to 40% for more than 4 seconds) and a huge number of process lines from OUTLOOK and other, possibly related processes (a.o. indexer, McAfee).

It may well be that a third application/process (with Outlook and LibreOffice being the 2 others) has a role in it. And as the problem is a delay when mving the caret in an Outlook message, I see no way to use windebug to catch something in LibreOffice.

Setting the status to unconfirmed and hoping that someone else experiences a likewise problem but has more clues.
Comment 11 Michael Meeks 2014-11-04 09:19:22 UTC
Moving the caret - that's really odd. Of course it could be IAccessible - try disabling a11y [ if that's even possible anymore on windows - I think there is an environment variable for that though if you grok the code in vcl / winaccessibility ]. Then again, that wasn't present in 3.6.5 =)
It could be thumbnailing attachments (I guess) - if we do that.
It'd be interesting to know if sysinternals shows what is happening on the system when you move the caret: is a file saved (perhaps we're being used to thumbnail that or something ? ;-)

Very odd.
Comment 12 Winfried Donkers (retired) 2014-11-04 10:29:04 UTC
Created attachment 108882 [details]
logfile of processmonitor

Actions taken (Windows7, Outlook2010, LO4.2.7):
-open new Calc document (and minimize)
-open Outlook
-open new E-Mail message
-type lines
-start processmonitor
-cut some text (Ctrl-X) and move caret some lines down
-save processmonitor log

What looks strange to me is line 300, where soffice starts a thread. Why would that be?

It is not doable for me to time my actions with the lines in the log, the processmonitor makes me dizzy.
Comment 13 Winfried Donkers (retired) 2014-11-04 10:30:38 UTC
(In reply to Winfried Donkers from comment #12)
> Created attachment 108882 [details]
> logfile of processmonitor

BTW, a lot of processes are filtered out (svchost, wmiprvse. etc.)
Comment 14 Winfried Donkers (retired) 2014-11-06 12:49:22 UTC
Created attachment 109032 [details]
logfile(2) of processmonitor

same steps as yesterday.
Processexplorer shows cpu-activity of 40-50% for outlook.exe, no activity that's worth mentioning for soffice.

Loglines 110-120 seemed to coincide with the slowness -hard to be sure as the processmonitor 'freezes' at times and only later catches up-.

The activities from soffice don't seem to take much time.

A collaegue, who has the slowness the other way round (slow Writer when Outlook is open) is trying to catch some traces of that behaviour.
Comment 15 Michael Meeks 2014-11-06 17:14:17 UTC
Nothing much in the processmonitor log. You sure it's not just memory pressure or something ? =) it sounds really unusual.
Comment 16 Winfried Donkers (retired) 2014-11-07 06:57:12 UTC
The machine I use for testing has sufficient memory (40% unused).
I feared that McAfee services could influence the behaviour, so I tested also with these services stopped: same behaviour.
With mcAfee services started again and calc closed (quickstarter still active) the outlook slowness was completely absent (i.e. I was stunned by the speed).
Comment 17 Winfried Donkers (retired) 2014-11-12 12:46:20 UTC
Created attachment 109333 [details]
logfile(3) of processmonitot

Taken from another machine experiencing slow Calc whilst Outlook was open.

Logged actions:
type anything in a cell of a calc document
press Enter
Outlook processor use rises to 25%, entering characters in calc is not visible (not processed by calc) for some seconds
Using the backspace key produces similar results.

The slowness could be reproduced for half an hour, then it disappeared.

(I've received similar reports with Writer instead of Calc, it's not module-specific.)
Comment 18 Robinson Tryon (qubit) 2015-01-20 07:55:24 UTC
(In reply to Winfried Donkers from comment #10)
> I can reproduce the behaviour on all machines in our company, 

(In reply to Winfried Donkers from comment #3)
> Case 2 in comment #1 bothers now several users.
> 

So not a 1-machine fluke...
Status -> NEW
Comment 19 Winfried Donkers (retired) 2015-02-13 09:54:43 UTC
Surprise: With Outlook we use a small aaa-in (Advanced_security from MAPILabs) that allows other applications to create/send e-mails with Outlook without messages asking for permission.

Disabling this add-on ends the slowing down of Outlook and/or LibreOffice :-)
(That creates another problem here, but has nothing to do with LibreOffice).

Thank you all for your suggestions in finding the cause!
Comment 20 Michael Meeks 2015-02-13 10:17:24 UTC
Phew ! thanks for the update, I've been idly fretting about this bug =) Good to know it's not our fault !