Bug 66674 - FILEOPEN: Calc sometimes freezes when opening ods file
Summary: FILEOPEN: Calc sometimes freezes when opening ods file
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 66514 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-07 21:20 UTC by mats.asson
Modified: 2014-08-17 11:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file that I sometimes get the freezing with (6.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-08 08:11 UTC, mats.asson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mats.asson 2013-07-07 21:20:42 UTC
Sometimes when I'm starting LO calc with one of my .ods files it freezes. I found that I can get it to work again by stopping the windows process splwow64.exe. When I do that, calc resumes it's normal work and everything is ok. Splwow64.exe is a print spooler service for 32 bit programs. After stopping it, windows starts it again immediately but calc works.
Operating System: Windows 7
Version: 4.0.4.2 release
Comment 1 m.a.riosv 2013-07-07 23:11:13 UTC
Hi mats thanks for reporting.
Please can you attach a file with which reproduce the issue?. Remember delete/change any private information in it.
Comment 2 mats.asson 2013-07-08 08:11:20 UTC
Created attachment 82167 [details]
A test file that I sometimes get the freezing with

It doesn't matter what file I try to open when the freeze appears as long as it is an .ods file. I cannot open any ods file as long as I don't stop the splwow64.exe process. However, xls files opens normally. Also, it is only when I start my system and log in. When I stop splwow64 everything works normally until I log out. 

Also, the bug seems to appear approximately 1/3 of the times I log in. Could be some kind of timing between processes that starts after login.

Maybe this bug is related to an old one, #42673 that never seemed to be solved properly.
Comment 3 m.a.riosv 2013-07-08 21:54:04 UTC
Splwow64.exe is the "Print driver host for 32bit applications".

Maybe you have select local/net printer unavailable.

Can you do a try changing the default printer in LibreOffice, or changing the printer selected for the file if printer settings are saved with it. (Menu/Tools/Options/Load-Save/Load - Load printer settings with the document).
Comment 4 mats.asson 2013-07-31 08:32:22 UTC
Ok. I have tried for a while to have Nitro PDF Creator as my default printer and also removed the setting for loading the printer setting with the document. The problem remains. I think that LibreOffice shouldn't just freeze if the printer is not available though. There should be some kind of timeout and the document should still load. This is the only computer that I see this behaviour on.
Comment 5 Owen Genat (retired) 2013-09-08 22:19:18 UTC
*** Bug 66514 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2014-05-17 00:34:11 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 7 Herbert Geiger 2014-05-17 02:15:17 UTC
This bug disappeared on the way to version 4.2 in the last month i've never got this problem.

br
Comment 8 mats.asson 2014-05-19 17:32:48 UTC
I still have it on 4.2.1.1

Exactly the same way as before.
Comment 9 m.a.riosv 2014-05-19 18:17:18 UTC
Please Mats, can you try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile#Windows
Comment 10 mats.asson 2014-05-19 18:23:17 UTC
Sure. I'll try that. I'm pretty sure that I tried it before but I'll do it again. Since the problem doesn't always occur the answer can take a couple of weeks or so.
Comment 11 mats.asson 2014-05-20 16:04:06 UTC
So I've reset the user profile yesterday and the problem occured today. As soon as I stop the process Splwow64.exe LO continues to load the file.
Comment 12 m.a.riosv 2014-05-20 17:34:34 UTC
Maybe there is a matter with splwow64.exe, looking in the net for:
splwow64.exe hotfix windows 7
there are a lot of links related to, e.g.:
http://community.spiceworks.com/topic/354827-splwow64-exe-process-doesn-t-end-causes-excel-to-flicker
Comment 13 mats.asson 2014-05-20 19:46:40 UTC
Thank you for pointing that out. I've applied the Microsoft hotfix and will come back with more info here in a while.
Comment 14 mats.asson 2014-08-17 11:28:50 UTC
Another comment for this. It seems that this is not a bug in libreoffice. Lately I've found out that the same problem also applies when I'm working with pdf documents, both in adobe:s software and nitro pdf which I also am using. Yesterday, I couldn't print a pdf from neither of the two until I closed splwow64. It definitely seems to be a problem with splwow64 and not with libreoffice.