Bug Hunting Session
Bug 66744 - slow selection of Libreoffice entries in gnome-panel
Summary: slow selection of Libreoffice entries in gnome-panel
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-09 16:30 UTC by Kevin Hunter
Modified: 2017-08-17 20:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Hunter 2013-07-09 16:30:25 UTC
Background: Using Openbox + gnome-panel on Ubuntu 12.04.2 (x86_64), kernel 3.5, with 4 GB RAM.

Problem: Mousing over or keyboard+arrow -ing through any LibreOffice entries in the Office submenu of gnome-panel shows a noticeable delay.

This delay is noticeable, anywhere from .2s to 2s (anecdotal estimation) and does not exist for any non-Libreoffice entry in gnome-panel.  This is _not_ a first-time-only caching issue: when I hit up-and-down repeatedly enough times and then stop, I can watch two different menu entries get iteratively selected over an additional 5s as it "catches up" with my keystrokes.

NB: LibreOffice is _not_ open.  I'm assuming there's some interaction with .desktop files.

Per conversation with vmiklos on IRC, I installed the latest master build.  Copied from about box:

    Version: 4.2.0.0.alpha0+
    Build ID: b1c4046379b888bf3a82fbd31287ee3a68439968
    TinderBox: Linux-x86-64@8-SLED11, Branch:master, Time: 2013-07-09_00:35:08

I first recall seeing this in 3.6, so have listed that as the affected version, but it still exists per the alpha build listed above.

Nothing jumps out at me from a cursory inspection of gnumeric.desktop and writer.desktop, other than perhaps 2 Exec lines in writer.desktop, or the fact that it's symlinked.
Comment 1 Adolfo Jayme 2013-07-10 21:10:52 UTC
It may be that GNOME Panel is slow when reading the complex SVGs LibreOffice has as icons...
Comment 2 QA Administrators 2015-04-01 14:40:42 UTC Comment hidden (obsolete)
Comment 3 tommy27 2016-04-16 07:23:21 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-05-22 13:23:13 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2017-08-17 20:36:52 UTC
Nobody confirmed this bug report. As it has not been touched by its reporter since 3 years, I close it as insufficientdata. Please feel free to reopen if you disagree.

Best regards. JBF