Bug 66760 - Personas don't paint toolbar correctly under KDE's Plastik style
Summary: Personas don't paint toolbar correctly under KDE's Plastik style
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-10 09:44 UTC by mal
Modified: 2015-06-08 14:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Toolbar with persona not displaying properly (100.59 KB, image/png)
2013-07-10 09:44 UTC, mal
Details
Picture of personas not displayed correctly (100.59 KB, image/png)
2013-07-10 09:47 UTC, mal
Details
I fail to reproduce (178.69 KB, image/png)
2013-07-10 09:52 UTC, Jorendc
Details
ugly icons using personas (92.02 KB, image/jpeg)
2014-05-24 15:49 UTC, Heiko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mal 2013-07-10 09:44:38 UTC
Created attachment 82264 [details]
Toolbar with persona not displaying properly

When you install personas the area under the toolbar buttons don't
get coloured. When you move the mouse over active ones they get 
painted.

See attached screenshot

OpenSuse 12.3 KDE 4.10.5 LO 4.1 rc2
Comment 1 mal 2013-07-10 09:47:11 UTC
Created attachment 82265 [details]
Picture of personas not displayed correctly
Comment 2 Jorendc 2013-07-10 09:52:12 UTC
I fail to reproduce using Linux Mint 15 x64 with LibreOffice 4.1.0.2.
https://addons.mozilla.org/en-US/firefox/addon/libreoffice-green/ draws perfectly.

Kind regards,
Joren
Comment 3 Jorendc 2013-07-10 09:52:40 UTC
Created attachment 82266 [details]
I fail to reproduce
Comment 4 mal 2013-07-10 09:56:41 UTC
That looks like a Mint desktop. Mine is KDE 4.10.5
Comment 5 mal 2013-07-11 07:19:59 UTC
I am using air-oxygen style
Comment 6 Marco Menardi 2014-01-04 16:57:27 UTC
I've tried with 4.1.4~rc2 and 4.2.0 rc1, under 4.12 kubuntu, green libreoffice theme, and oxygen (don't know if "air") kde theme and works fine.
I suggest you to try to delete /var/tmp/kdecache* directories (log out KDE, open the terminal crtrl+alt+F1, login and $ sudo rm -r /var/tmp/kdecache-* ) and reboot.
In the past I had similar issues with kde itself due to "old and dirty" data cached there.
Comment 7 Heiko 2014-05-24 15:48:02 UTC
can reprodue the problem
LO 4.2.4.2 & LO 4.3.0.beta1, OpenSuse 12.3, KDE 4.13.1.
Comment 8 Heiko 2014-05-24 15:49:45 UTC
Created attachment 99717 [details]
ugly icons using personas
Comment 9 steve 2014-10-27 12:31:30 UTC
Not reproducible on OSX 10.10, LO Version: 4.3.3.1
Build ID: 7d55112667c8fcddb67bc3803796b46c93aa56b0

This is a Linux only bug. Setting Hardware OS accordingly.
Comment 10 Thomas Hackert 2014-11-01 17:52:48 UTC
Hello mal, *,
I cannot reproduce it with LO

Version: 4.3.3.1.0+ Build-ID: 430m0(Build:1)

nor with my parallel installed

Version: 4.4.0.0.alpha1+ Build ID: 1baad070d8c2a38581cf33d803c5043f1974647f TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-01_00:19:59

(following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) on Debian Testing i686 with KDE 4.14.1, sorry ... :( I have switched my used Oxygen to Plastique (which should be identical to your mentioned Plastik in the summary), restarted both LOs, but to no avail ... :(

Have you tried it with a newer version of LO than 4.1.0.2rc (which is rather oldish, btw. ... ;) )? Which video chip/card are you using and which driver? Are you using any 3D effects in KDE?

Sorry for the inconvenience and have a nice evening
Thomas.
Comment 11 QA Administrators 2015-05-06 14:15:02 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 12 QA Administrators 2015-06-08 14:26:40 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team 

This INVALID Message was generated on: 2015-05-06

Warm Regards,
QA Team