Download it now!
Bug 66823 - Formula getting erased if using different sheet in LOOKUP function inside IF function
Summary: Formula getting erased if using different sheet in LOOKUP function inside IF ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2013-07-11 13:55 UTC by Michael Tiernan
Modified: 2015-12-17 07:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
My document it has a lot of 'mathematical formula'. (181.91 KB, application/vnd.oasis.opendocument.text)
2014-06-04 23:47 UTC, Jose Luis Triana
Details
Example files for proof. (1.19 MB, application/zip)
2014-06-05 15:33 UTC, Michael Tiernan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Tiernan 2013-07-11 13:55:07 UTC
While working on another issue I found that a reasonably simple compound formula causes the editor to wipe previous level of formula.

Example. Formula contains:
=IF(D3="String",LOOKUP(G3,'file'#Sheet1.CcR1:CcR60,'file'#Sheet1.CdR1:CdR60),"Empty")

If, during the editing process, after the first selection of "'file'#Sheet1.CcR1:CcR60" one returns to the editor and clicks in the NEXT field (Result Vector for LOOKUP), the previous level of formula (The IF) goes away.

I have a short video (1min) showing this happening if requested. I'd prefer to not make it public by attaching it.

*THIS* Issue I've tested and repeated multiple times.
Comment 1 retired 2013-11-22 18:49:10 UTC
Can you please provide a test document so this can be tested against and subsequently be confirmed.

Also, does this still happen with LO 4.1.3.2?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 2 QA Administrators 2014-06-01 21:30:05 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Jose Luis Triana 2014-06-04 23:47:06 UTC
Created attachment 100426 [details]
My document it has a lot of 'mathematical formula'.
Comment 4 Jose Luis Triana 2014-06-04 23:47:42 UTC
It affects me as well, this bug happens random, as well in libreoffice writer 4.2.3.3, x86_64 in Linux (Ubuntu 14.04)     

Sooner or later when I click on a formula then click with the mouse right button, or whatever the button is set for context menus and so on, the "formula" or equation just gets blank at the moment the equation editor goes on the window, and the command window of the editor is empty. 

annoying of course when I want to edit a very big matrix, and then good bye. 

This bug should be critical it affects productivity.
Comment 5 Michael Tiernan 2014-06-05 14:09:19 UTC
Sorry, been wrapped up in my own affairs, haven't been able to log in for this.

I will see if I can create a sample.
Comment 6 Michael Tiernan 2014-06-05 15:32:35 UTC
(In reply to comment #5)
> Sorry, been wrapped up in my own affairs, haven't been able to log in for
> this.
> 
> I will see if I can create a sample.

I finally got it done.

I'll attach a zip file with five entries.
Two screen shots.
A text file describing the steps I've taken to trigger the error.
Two spreadsheets used in the example.
Comment 7 Michael Tiernan 2014-06-05 15:33:41 UTC
Created attachment 100473 [details]
Example files for proof.
Comment 8 Michael Tiernan 2014-06-05 15:36:47 UTC
Sorry, I meant to add, I did this using the most recent download:
Version: 4.1.6.2
Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
Comment 9 ign_christian 2014-08-30 03:34:25 UTC
Following procedure on Sequence_Followed.txt in zip attached, reproducible with LO 4.2.6.3 - Ubuntu 12.04 x86

All functions is lost (seen on tab "Structure" in "Function Wizard") after 'result vector' defined.

Bug not occured if we use same worksheet in 'Search vector' and 'result vector' within LOOKUP function (which is inside IF function).

Bug also not occured if we use LOOKUP function alone, not inside IF function.

Set version 4.1.6.2 per comment 8 to indicate the first appearance of this bug.
Comment 10 ign_christian 2014-08-30 03:47:38 UTC
Not reproduced with LO 4.0.6.2 -> regression
Comment 11 Matthew Francis 2015-01-29 11:12:50 UTC
I can reproduce this on OSX / LO 4.0.0.4, but can no longer reproduce on LO 4.3.5.1 or 4.4.0.2

Setting RESOLVED - WORKSFORME (as the exact commit which fixed this has not been identified)
Comment 12 Robinson Tryon (qubit) 2015-12-17 07:16:08 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]