Bug 66919 - printing multiple documents does not work in Windows 8
Summary: printing multiple documents does not work in Windows 8
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-15 11:18 UTC by tommy27
Modified: 2014-02-12 16:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
One of the five test files (11.95 KB, application/vnd.oasis.opendocument.text)
2013-07-17 17:15 UTC, Mark Ellse
Details
Second of the five test files (11.62 KB, application/vnd.oasis.opendocument.text)
2013-07-17 17:15 UTC, Mark Ellse
Details
Third of the five test files (12.09 KB, application/vnd.oasis.opendocument.text)
2013-07-17 17:16 UTC, Mark Ellse
Details
Fourth of the five test files (11.63 KB, application/vnd.oasis.opendocument.text)
2013-07-17 17:17 UTC, Mark Ellse
Details
Fifth and last of the five test files (11.98 KB, application/vnd.oasis.opendocument.text)
2013-07-17 17:17 UTC, Mark Ellse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2013-07-15 11:18:53 UTC
this issue was created from: 
https://bugs.freedesktop.org/show_bug.cgi?id=33484#c24

------------
Mark Ellse  2013-07-12 12:14:11 UTC 
Upto and including 4.04.2, printing multiple documents works in Windows 7, but does not work in Windows 8
-----------
Comment 1 retired 2013-07-16 11:39:13 UTC
tommy27: Could you provide detailed steps on how to reproduce this problem? Please attach a sample document and / or exact steps leading to the problem. After that, please re-set the bug to UNCONFIRMED.
Comment 2 tommy27 2013-07-16 12:06:32 UTC
@James
please note that I just cloned a bug report from another one.
the original reporter is Mark Ellse.

I agree that more informations are needed.
so, please Mark, tell us which is your problem.
Comment 3 ign_christian 2013-07-16 13:44:18 UTC
I think original description in that bug is enough to explain steps to reproduce:
https://bugs.freedesktop.org/show_bug.cgi?id=33484#c0
Comment 4 tommy27 2013-07-16 14:09:02 UTC
@ign_christian  
I'm not sure that user Mark Ellse is experiencing the same issue of previous bug... 

so I'm waiting for direct confirmation from him, unless you can confirm yourself the troubles he was talking about with Win8 and printing multiple files.

unfortunately I have only WinXp, WinVista and Win7 machines to test.
do you have a Win8 computer?

I'm reverting status to NEEDINFO
Comment 5 ign_christian 2013-07-16 14:29:52 UTC
> so I'm waiting for direct confirmation from him, unless you can confirm
> yourself the troubles he was talking about with Win8 and printing multiple
> files.
> 
> unfortunately I have only WinXp, WinVista and Win7 machines to test.
> do you have a Win8 computer?
Sorry for that interuption. Unfortunately I also don't have it :)
Comment 6 Mark Ellse 2013-07-17 17:15:18 UTC
Created attachment 82553 [details]
One of the five test files
Comment 7 Mark Ellse 2013-07-17 17:15:47 UTC
Created attachment 82554 [details]
Second of the five test files
Comment 8 Mark Ellse 2013-07-17 17:16:19 UTC
Created attachment 82555 [details]
Third of the five test files
Comment 9 Mark Ellse 2013-07-17 17:17:00 UTC
Created attachment 82556 [details]
Fourth of the five test files
Comment 10 Mark Ellse 2013-07-17 17:17:31 UTC
Created attachment 82557 [details]
Fifth and last of the five test files
Comment 11 Mark Ellse 2013-07-17 17:41:16 UTC
Problem defined more clearly:
If you try to print multiple files in Win8, only two of them will print. In Win7, multiple file printing works.

To reproduce:
Stick the attached files in a folder. Drag them to the printer. Only 2 of the 5 print with Win8. With Win7, all print.

If you rename the files to have the same length of file name, eg 1 Abcd.odt, 2 Abcd.odt, etc, they all print.
Comment 12 QA Administrators 2014-02-02 02:06:39 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 13 Mark Ellse 2014-02-10 23:53:54 UTC
Sorry for delay in coming back.
This bug still exists. Drag and drop printing more than two files prints only the first two, unless all the files names are the same length. But the bug is present when printing text files via Notepad or Wordpad (and odt files via Wordpad as well) so it must be a Windows problem. Still evident in Windows 8.1.
Comment 14 tommy27 2014-02-11 06:53:54 UTC
back to UNCONFIRMED. we need a Win8 QA member to test.
Comment 15 Jorendc 2014-02-12 16:18:44 UTC
Tested using Windows 8.1

* Download attached documents
* Drag them to the print queue

Observation: as Comment 13 : only 2 pages added to the queue

* Rename all files so they have same name length

Observation: as Comment 13 : all pages are added to the queue

But this has nothing to do with LibreOffice because doing the same with random downloaded images result in the same behavior as mentioned above.

So: Windows 8 bug, not our bug. Marking as such.

Kind regards,
Joren