Bug 67084 - ASKLIBREOFFICE: Comment formatting under Askbot v0.7.48
Summary: ASKLIBREOFFICE: Comment formatting under Askbot v0.7.48
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-19 12:40 UTC by Owen Genat (retired)
Modified: 2013-08-20 05:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2013-07-19 12:40:59 UTC
Problem description: Not all formatting options available when editing a question or answer are available in comments.

Steps to reproduce:
1. Open the wiki-style playground thread: http://ask.libreoffice.org/en/question/3598/is-there-a-wiki-style-playground-on-this-site/
2. Try to use any of the following formatting:
   a. In-line code: `~/.bashrc`
   b. Bug link: fdo#123456
   c. Internet link: [wikipedia](http://www.wikipedia.org/)
   d. Italic text: *italic*
   e. Bold text: **bold**

Current behavior: Text is displayed as plain text in all cases.

Expected behavior: Text is displayed in the formatted form (as occurs in a question or answer).

This has only stopped functioning for the examples shown since the upgrade to Askbot v0.7.48 on 4th July 2013.
              
Operating System: All
Version: 4.0.4.2 release
Comment 1 Owen Genat (retired) 2013-07-19 12:44:00 UTC
Adding Qubit to the CC list. Will leave it to the QA team to confirm.
Comment 2 manj_k 2013-07-19 13:19:06 UTC
The corresponding settings:

Settings → Data rules & Formatting → Data entry and display rules →
Editor for the comments [1]

Enabled: Plain text editor
Disabled: Same editor as for questions and answers

[1] http://ask.libreoffice.org/en/settings/FORUM_DATA_RULES/

Is it an intentional modification?
Comment 3 Robinson Tryon (qubit) 2013-07-19 13:25:10 UTC
Regressions confirmed.

Another regression from the previous version of askbot: hard returns.

Two carriage returns (using CTRL-ENTER) in a comment used to render as a single carriage return. That formatting now renders as the empty string.

Personally, I'd like to use the same syntax in comments and in answers (see my suggestion here: http://askbot.org/en/question/10091/why-do-comments-have-a-different-syntax-than-answers/ )
Comment 4 Owen Genat (retired) 2013-07-20 03:18:51 UTC
Just a few minor additions. The related AskLO thread (for completeness) is:

http://ask.libreoffice.org/en/question/20381/in-comments-how-to-insert-a-clickable-link-to-a-reported-bug/

It appears the strikethrough syntax does work in comments under v0.7.48. I just tested it here:

http://ask.libreoffice.org/en/question/3598/is-there-a-wiki-style-playground-on-this-site/?answer=20522#post-id-20522

The matter of quoting in a comment I am less certain of as I guess I would generally just use quotation marks. Am I misunderstanding what is suggested here in comment #3? The matter of line feed / new line (CTRL+ENTER) rendering as an empty string is confirmed. I don't think I have used this, although it could be useful.
Comment 5 Evgeny Fadeev 2013-07-20 04:41:44 UTC
That's correct the default plain text editor in the comments does not support markdown, but it's possible to use the same editor for the comments as the one used for the questions and the answers.
Comment 6 Owen Genat (retired) 2013-07-21 00:12:09 UTC
I have just noticed a further issue with how userids are handled. When responding using a comment in this thread:

http://ask.libreoffice.org/en/question/20545/is-there-a-simple-way-to-convert-lotus-files-without-first-converting-them-to-excel/

... I typed "@jhpoletti@orcasonline.com" to direct my comment at the OP instead of the initial comment by manj_k and the resultant text that has displayed is "<@jhpoletti@orcasonline.com">p>@jhpoletti@orcasonline.com". Admittedly this would seem to me an unusual userid, but perhaps this form of userid automatically results from one of the offered signin methods? In any case it needs to be handled better than it currently is (at least for these less common forms).

> it's possible to use the same editor for the comments as the one used for the questions and the answers

Thanks Evgeny. So standard HTML markup will work. Is there a particular HTML markup code that is needed for userid references?
Comment 7 Evgeny Fadeev 2013-07-21 00:18:44 UTC
This is a separate issue @user@example.com - apparently does not work for user names that are email addresses. Simply @user works.

RE: editor - just go to the settings available to the admins and change comments editor to "the same as editor for questions".
Comment 8 bugquestcontri 2013-07-21 03:17:38 UTC
The current editor for comments does not allow paragraphs, new lines, thus limiting the possibilities to put more clarity into a comment. A better editor would be very helpful and would also decrease the usage of Answers when a Comment could be more appropriate.
Comment 9 retired 2013-07-21 10:52:34 UTC
What's the status of this bug? Sounds like several bugs being named here. Policy is one bug per issue.

Is this NEW, since Qubit seems to be onfirming this?
Comment 10 Robinson Tryon (qubit) 2013-07-21 15:53:17 UTC
(In reply to comment #9)
> What's the status of this bug? Sounds like several bugs being named here.
> Policy is one bug per issue.

I think all/most of these issues are caused by or related to our current comment settings in Askbot. There might be a couple of outliers that don't fit-in, but once we resolve the comment-formatting question, the chaff will fall away and the remaining issues will be easier to spot :-)

> 
> Is this NEW, since Qubit seems to be onfirming this?

I'll mark this as NEW (as it is a real issue and we're working on how best to address it).

See our discussion here (comments on the Question itself):
http://ask.libreoffice.org/en/question/3598/is-there-a-wiki-style-playground-on-this-site/
Comment 11 manj_k 2013-08-05 06:45:03 UTC
I would propose to enable
"Editor for the comments: Same editor as for questions and answers"
on a trial basis.

Any objections?
Comment 12 Robinson Tryon (qubit) 2013-08-05 12:52:54 UTC
(In reply to comment #11)
> I would propose to enable
> "Editor for the comments: Same editor as for questions and answers"
> on a trial basis.
> 
> Any objections?

Nobody has complained or voiced dissent on the mailing list, so I think it's fine to enable this feature for now.

[I'll go do that now...]
Comment 13 Evgeny Fadeev 2013-08-05 17:32:43 UTC
Ok, maybe actually we should have the same editor for the comments as for Q&A to avoid all the confusions.
Comment 14 Owen Genat (retired) 2013-08-20 05:56:35 UTC
I am setting this bug RESOLVED as FIXED, since the question editor has now been turned on for the comments as well and appears to work as expected for the cases I originally reported. Thanks to everyone who assisted with this.