Bug 67097 - binding to data lost when saved as fods
Summary: binding to data lost when saved as fods
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: lowest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2013-07-19 18:03 UTC by Lennard Wasserthal
Modified: 2021-10-10 03:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
initial chart pie.ods (18.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-17 16:53 UTC, pierre-yves samyn
Details
converted flat pie.fods (49.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-17 16:54 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lennard Wasserthal 2013-07-19 18:03:22 UTC
Steps to reproduce:
1. Create Data in calc
2. Create a chart in calc with a table as this data
3. save as fods
4. close and load again
=> In the chart, you can't select a data source anymore. You can just edit a 
=> note that when you switched x/y axis for that chart, it is also flipped back.
Comment 1 Lennard Wasserthal 2013-07-19 18:05:56 UTC
=> In the chart, you can't select a data source anymore. You can just edit a "Diagram Data Table". Switching x/y data axis is not necessary.
Comment 2 Lennard Wasserthal 2013-07-19 18:06:41 UTC
And yes, the data coherency is broken
Comment 3 pierre-yves samyn 2014-01-17 16:52:12 UTC
Hello 

I confirm on windows 7/64 with Version: 4.2.0.2
Build ID: cd65d6220c5694ee7012d7863bcde3455c9e3c30

and Version: 4.3.0.0.alpha0+
Build ID: ae8e579515fff84cbef1ccc2da78fa769fb079ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-10_11:16:31


Regards
Comment 4 pierre-yves samyn 2014-01-17 16:53:33 UTC
Created attachment 92292 [details]
initial chart pie.ods
Comment 5 pierre-yves samyn 2014-01-17 16:54:04 UTC
Created attachment 92293 [details]
converted flat pie.fods
Comment 6 Joel Madero 2015-05-02 15:41:08 UTC Comment hidden (obsolete)
Comment 7 pierre-yves samyn 2015-05-09 10:29:30 UTC
Hi

The bug no more occurs on windows 7/64 & Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fr_FR

I do not set status to RESOLVED WORKSFORME because there is another problem: it is necessary to force the update of the chart (Ctrl+Shift+ F9) to drawn it.

Steps to reproduce:
1. open attachment 92292 [details]
2. File> Save As fods
3. close and load again

Expected result: chart in the same "state" as before
Actual result: the chart is not drawn (except the legend)

you have to update with Ctrl+Shift+ F9.

I suppose it would open another bug but I let the reporter to decide

Regards
Pierre-Yves
Comment 8 QA Administrators 2016-09-20 09:41:43 UTC Comment hidden (obsolete)
Comment 9 pjryynan 2019-10-10 15:24:15 UTC
Since this has been included in the chart improvement meta ticket last year, perhaps it'll be worthwhile to explain my steps to repeat it. This became a bit of a hindrance to us at work.

This is with LibreOffice 6.0.7.3 on Ubuntu 18.04. (Build ID: 1:6.0.7-0ubuntu0.18.04.10)

1. Run LibreOffice Calc. It opens new untitled document.
2. Add second sheet and insert number 1 into cells A1:B2
3. Go back to first sheet, click Create Chart and Finish.
4. Edit chart data range to point to $Sheet2.$A$1:$Sheet2.$B$2 by selecting and right click menu.
5. Save file as .fods, close LibreOffice, reopen file.
6. Now the chart on sheet 1 looks ok but data ranges can no longer be changed via right click menu.

Note that while trying to come up with simple steps to do this, I tried putting a chart in sheet2 that referred to a range sheet1. That one didn't break upon reopening libreoffice/document. I then dragged sheet2 to left of sheet1, saved and restarted+reopened. Chart on "sheet2" (the leftmost sheet) broke. (Lost bindings?) It was not fixable by dragging the sheet to the right and restarting.
Comment 10 QA Administrators 2021-10-10 03:44:17 UTC
Dear Lennard Wasserthal,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug